summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-12 21:05:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-08-12 21:05:15 +0000
commitd6f089f10d7db73871001addebc9a4fdfda109bb (patch)
tree421cb222a6c2562676103a91487e7af810394b88 /kde-base/ffmpegthumbs
parentMask xv-3.10a-r16, since it breaks saving PNG files (see bug #355883) (diff)
downloadgentoo-2-d6f089f10d7db73871001addebc9a4fdfda109bb.tar.gz
gentoo-2-d6f089f10d7db73871001addebc9a4fdfda109bb.tar.bz2
gentoo-2-d6f089f10d7db73871001addebc9a4fdfda109bb.zip
Fix build against newer ffmpeg / libav, bug 369515
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ffmpegthumbs')
-rw-r--r--kde-base/ffmpegthumbs/ChangeLog6
-rw-r--r--kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild4
-rw-r--r--kde-base/ffmpegthumbs/files/ffmpegthumbs-4.6.5-libav07.patch11
3 files changed, 19 insertions, 2 deletions
diff --git a/kde-base/ffmpegthumbs/ChangeLog b/kde-base/ffmpegthumbs/ChangeLog
index 18ae43ee62e0..15f91aafe418 100644
--- a/kde-base/ffmpegthumbs/ChangeLog
+++ b/kde-base/ffmpegthumbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/ffmpegthumbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.25 2011/08/12 19:19:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ChangeLog,v 1.26 2011/08/12 21:05:15 dilfridge Exp $
+
+ 12 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ ffmpegthumbs-4.6.5.ebuild, +files/ffmpegthumbs-4.6.5-libav07.patch:
+ Fix build against newer ffmpeg / libav, bug 369515
12 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-ffmpegthumbs-4.6.4.ebuild:
diff --git a/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild b/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild
index 594cdb418a26..cd452dea836f 100644
--- a/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild
+++ b/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild,v 1.2 2011/08/09 17:12:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ffmpegthumbs/ffmpegthumbs-4.6.5.ebuild,v 1.3 2011/08/12 21:05:15 dilfridge Exp $
EAPI=4
@@ -15,3 +15,5 @@ DEPEND="
virtual/ffmpeg
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.6.5-libav07.patch" )
diff --git a/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.6.5-libav07.patch b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.6.5-libav07.patch
new file mode 100644
index 000000000000..931de168e48b
--- /dev/null
+++ b/kde-base/ffmpegthumbs/files/ffmpegthumbs-4.6.5-libav07.patch
@@ -0,0 +1,11 @@
+--- branches/KDE/4.7/kdemultimedia/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp 2011/07/02 08:19:20 1239063
++++ branches/KDE/4.7/kdemultimedia/ffmpegthumbs/ffmpegthumbnailer/moviedecoder.cpp 2011/07/02 08:23:18 1239064
+@@ -122,7 +122,7 @@
+ void MovieDecoder::initializeVideo()
+ {
+ for (unsigned int i = 0; i < m_pFormatContext->nb_streams; i++) {
+- if (m_pFormatContext->streams[i]->codec->codec_type == CODEC_TYPE_VIDEO) {
++ if (m_pFormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO) {
+ m_pVideoStream = m_pFormatContext->streams[i];
+ m_VideoStream = i;
+ break;