summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-30 17:42:32 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-30 17:42:32 +0000
commitb3a79930848a5138715e277e4a95268a97b4e042 (patch)
tree38a4644bc2269965226674f6c3f5a016983a4b10 /gnome-extra/gal
parentMarked as stable. See bug #9404 for details. (diff)
downloadgentoo-2-b3a79930848a5138715e277e4a95268a97b4e042.tar.gz
gentoo-2-b3a79930848a5138715e277e4a95268a97b4e042.tar.bz2
gentoo-2-b3a79930848a5138715e277e4a95268a97b4e042.zip
Fix symlink issue
Diffstat (limited to 'gnome-extra/gal')
-rw-r--r--gnome-extra/gal/ChangeLog7
-rw-r--r--gnome-extra/gal/files/digest-gal-0.20-r1 (renamed from gnome-extra/gal/files/digest-gal-0.20)0
-rw-r--r--gnome-extra/gal/gal-0.20-r1.ebuild57
3 files changed, 63 insertions, 1 deletions
diff --git a/gnome-extra/gal/ChangeLog b/gnome-extra/gal/ChangeLog
index a8cf60571bfa..3266f907b669 100644
--- a/gnome-extra/gal/ChangeLog
+++ b/gnome-extra/gal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gal
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/ChangeLog,v 1.9 2002/09/28 07:08:50 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/ChangeLog,v 1.10 2002/10/30 17:42:32 foser Exp $
+
+*gal-0.20-r1 (30 Oct 2002)
+
+ 30 Oct 2002; foser <foser@gentoo.org> gal-0.20-r1.ebuild :
+ Add a fix for symlink problem
*gal-0.20 (28 Sep 2002)
28 Sep 2002; Martin Schlemmer <azarah@gentoo.org> :
diff --git a/gnome-extra/gal/files/digest-gal-0.20 b/gnome-extra/gal/files/digest-gal-0.20-r1
index bb96c4bedad5..bb96c4bedad5 100644
--- a/gnome-extra/gal/files/digest-gal-0.20
+++ b/gnome-extra/gal/files/digest-gal-0.20-r1
diff --git a/gnome-extra/gal/gal-0.20-r1.ebuild b/gnome-extra/gal/gal-0.20-r1.ebuild
new file mode 100644
index 000000000000..9d7504139928
--- /dev/null
+++ b/gnome-extra/gal/gal-0.20-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gal/gal-0.20-r1.ebuild,v 1.1 2002/10/30 17:42:32 foser Exp $
+
+IUSE="nls alsa"
+
+inherit gnome.org libtool
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Gnome Application Libraries"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/python
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.11
+ sys-devel/perl
+ <gnome-base/gnome-vfs-1.9.0
+ >=dev-libs/libunicode-0.4-r1
+ alsa? ( >=media-libs/alsa-lib-0.5.10 )
+ >=gnome-base/gnome-print-0.34
+ =gnome-base/libglade-0*
+ >=dev-libs/libxml-1.8.16"
+
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ use nls || myconf="--disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ # Add some type of backward compat...
+ local fullname=$(python -c "import os; \
+ print os.path.realpath(\"${D}/usr/lib/libgal.so\")")
+ dosym ${fullname##*/} /usr/lib/libgal.so.$((${PV##*.}-1))
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+