summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 22:55:50 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 22:55:50 +0000
commit460e2964dcf0c7f91d034eee08893eca2d8771a1 (patch)
tree8144cef1778354d9ec0f08a719c3604fe26434ec /gnome-extra/evolution-data-server
parentStable for ia64, wrt bug #457340 (diff)
downloadgentoo-2-460e2964dcf0c7f91d034eee08893eca2d8771a1.tar.gz
gentoo-2-460e2964dcf0c7f91d034eee08893eca2d8771a1.tar.bz2
gentoo-2-460e2964dcf0c7f91d034eee08893eca2d8771a1.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog8
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.8.0.ebuild125
-rw-r--r--gnome-extra/evolution-data-server/metadata.xml1
3 files changed, 133 insertions, 1 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 8943607a804a..ccdb982a6174 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.362 2013/02/24 11:25:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.363 2013/03/28 22:55:50 pacho Exp $
+
+*evolution-data-server-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org>
+ +evolution-data-server-3.8.0.ebuild, metadata.xml:
+ Version bump for Gnome 3.8
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
evolution-data-server-2.32.3-r3.ebuild:
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.8.0.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.8.0.ebuild
new file mode 100644
index 000000000000..17a419583fd4
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.8.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-3.8.0.ebuild,v 1.1 2013/03/28 22:55:50 pacho Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3,3} )
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit db-use eutils flag-o-matic gnome2 python-any-r1 vala versionator virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/40" # subslot = libcamel-1.2 soname version
+IUSE="api-doc-extras google +gnome-online-accounts +gtk +introspection ipv6 ldap kerberos vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.34:2
+ >=dev-db/sqlite-3.5:=
+ >=dev-libs/libgdata-0.10:=
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/libical-0.43:=
+ >=net-libs/libsoup-2.40.3:2.4
+ >=dev-libs/libxml2-2
+ >=sys-libs/db-4:=
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=app-crypt/gcr-3.4
+
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ gtk? ( >=x11-libs/gtk+-3.2:3 )
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.7.90
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.5:2= )
+"
+DEPEND="${RDEPEND}
+ dev-util/fix-la-relink-command
+ dev-util/gperf
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35.5
+ >=gnome-base/gnome-common-2
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2
+
+# FIXME
+#RESTRICT="test"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ # FIXME: Fix compilation flags crazyness
+ # Touch configure.ac if doing eautoreconf
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure || die "sed failed"
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable api-doc-extras gtk-doc) \
+ $(use_with api-doc-extras private-docs) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable introspection) \
+ $(use_enable ipv6) \
+ $(use_with kerberos krb5 "${EPREFIX}"/usr) \
+ $(use_with ldap openldap) \
+ $(use_enable vala vala-bindings) \
+ $(use_enable weather) \
+ $(use_enable gtk) \
+ $(use_enable google) \
+ --enable-nntp \
+ --enable-largefile \
+ --enable-smime \
+ --with-libdb="${EPREFIX}"/usr \
+ --disable-uoa
+}
+
+src_install() {
+ # Prevent this evolution-data-server from linking to libs in the installed
+ # evolution-data-server libraries by adding -L arguments for build dirs to
+ # every .la file's relink_command field, forcing libtool to look there
+ # first during relinking. This will mangle the .la files installed by
+ # make install, but we don't care because we will be punting them anyway.
+ fix-la-relink-command . || die "fix-la-relink-command failed"
+ gnome2_src_install
+
+ if use ldap; then
+ MY_MAJORV=$(get_version_component_range 1-2)
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema || die "doins failed"
+ dosym /usr/share/${PN}-${MY_MAJORV}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset ORBIT_SOCKETDIR
+ unset SESSION_MANAGER
+ export XDG_DATA_HOME="${T}"
+ unset DISPLAY
+ Xemake check || die "Tests failed."
+}
diff --git a/gnome-extra/evolution-data-server/metadata.xml b/gnome-extra/evolution-data-server/metadata.xml
index db353b52bbbf..54c4be5eea4a 100644
--- a/gnome-extra/evolution-data-server/metadata.xml
+++ b/gnome-extra/evolution-data-server/metadata.xml
@@ -6,6 +6,7 @@
<flag name="api-doc-extras">Build documentation for private APIs</flag>
<flag name="gnome-online-accounts">Enable using
<pkg>net-libs/gnome-online-accounts</pkg> for authorization</flag>
+ <flag name="google">Enable Google Contacts support</flag>
<flag name="vala">Build <pkg>dev-lang/vala</pkg> bindings</flag>
<flag name="weather">Enable optional weather calendar support</flag>
</use>