summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 16:25:38 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 16:25:38 +0000
commit1c2156c5df55319e608b14954245d3eddaa88004 (patch)
treee7e2defe1d182f52a15c9bbd8d82ec200dbe6714 /gnome-extra/at-spi
parentAdd new version for Gnome 2.30 (diff)
downloadgentoo-2-1c2156c5df55319e608b14954245d3eddaa88004.tar.gz
gentoo-2-1c2156c5df55319e608b14954245d3eddaa88004.tar.bz2
gentoo-2-1c2156c5df55319e608b14954245d3eddaa88004.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog7
-rw-r--r--gnome-extra/at-spi/at-spi-1.30.1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index f9f7ecc481ba..2c0c9e7c53c6 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.199 2010/06/04 20:09:04 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.200 2010/06/13 16:25:38 pacho Exp $
+
+*at-spi-1.30.1 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +at-spi-1.30.1.ebuild:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> at-spi-1.28.1.ebuild:
x86 stable, bug #314899
diff --git a/gnome-extra/at-spi/at-spi-1.30.1.ebuild b/gnome-extra/at-spi/at-spi-1.30.1.ebuild
new file mode 100644
index 000000000000..eaeeddaa3cc6
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.30.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.30.1.ebuild,v 1.1 2010/06/13 16:25:38 pacho Exp $
+
+inherit autotools eutils gnome2 python virtualx
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.29.2
+ >=x11-libs/gtk+-2.19.7
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-sm
+ --disable-xevie"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # should fix tests
+ epatch "${FILESDIR}"/${PN}-1.22.0-tests.patch
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_test() {
+ Xemake check || die "Testing phase failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/pyatspi
+}