summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 03:40:54 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 03:40:54 +0000
commitb8ca6bcadd0a157b4b6aa8933122254336f3554e (patch)
treea94d231e1d9aa3e876dc4cb5f4b089aeef47e900 /gnome-base/gnome-keyring
parentFix x86 compilation bug (thanks to David Abbott for the report, bug 390823). ... (diff)
downloadgentoo-2-b8ca6bcadd0a157b4b6aa8933122254336f3554e.tar.gz
gentoo-2-b8ca6bcadd0a157b4b6aa8933122254336f3554e.tar.bz2
gentoo-2-b8ca6bcadd0a157b4b6aa8933122254336f3554e.zip
Modernize the fcaps() error message; thanks to Steev Klimaszewski for noticing.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gnome-keyring')
-rw-r--r--gnome-base/gnome-keyring/ChangeLog7
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild11
-rw-r--r--gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild11
3 files changed, 18 insertions, 11 deletions
diff --git a/gnome-base/gnome-keyring/ChangeLog b/gnome-base/gnome-keyring/ChangeLog
index 7724e9ef332f..6d4c95f616bb 100644
--- a/gnome-base/gnome-keyring/ChangeLog
+++ b/gnome-base/gnome-keyring/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-keyring
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.215 2011/11/17 06:09:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/ChangeLog,v 1.216 2011/11/18 03:40:54 tetromino Exp $
+
+ 18 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-keyring-3.2.1.ebuild, gnome-keyring-3.2.2.ebuild:
+ Modernize the fcaps() error message; thanks to Steev Klimaszewski for
+ noticing.
*gnome-keyring-3.2.2 (17 Nov 2011)
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
index 49e3c820fb5d..f2e7fcca6119 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild,v 1.1 2011/10/30 07:21:57 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.1.ebuild,v 1.2 2011/11/18 03:40:54 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -101,10 +101,11 @@ fcaps() {
res=$?
if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missed kernel support."
- ewarn "Kernel must have SECURITY_FILE_CAPABILITIES, and <FS>_FS_SECURITY"
- ewarn "enabled (e.g. EXT3_FS_SECURITY) where <FS> is the filesystem to store"
- ewarn "${path}"
+ ewarn "Failed to set capabilities. Probable reason is missing kernel support."
+ ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
+ ewarn "where <FS> is the filesystem to store ${path}"
+ ewarn "If you are using kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
ewarn
ewarn "Falling back to suid now..."
chmod u+s ${path}
diff --git a/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild b/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
index 70d49ea4de08..83e9113166db 100644
--- a/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
+++ b/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild,v 1.1 2011/11/17 06:09:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-keyring/gnome-keyring-3.2.2.ebuild,v 1.2 2011/11/18 03:40:54 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -103,10 +103,11 @@ fcaps() {
res=$?
if [ $res -ne 0 ]; then
- ewarn "Failed to set capabilities. Probable reason is missed kernel support."
- ewarn "Kernel must have SECURITY_FILE_CAPABILITIES, and <FS>_FS_SECURITY"
- ewarn "enabled (e.g. EXT3_FS_SECURITY) where <FS> is the filesystem to store"
- ewarn "${path}"
+ ewarn "Failed to set capabilities. Probable reason is missing kernel support."
+ ewarn "Your kernel must have <FS>_FS_SECURITY enabled (e.g. EXT4_FS_SECURITY)"
+ ewarn "where <FS> is the filesystem to store ${path}"
+ ewarn "If you are using kernel 2.6.32 or older, you will also need to enable"
+ ewarn "SECURITY_FILE_CAPABILITIES."
ewarn
ewarn "Falling back to suid now..."
chmod u+s ${path}