summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-13 13:57:58 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-13 13:57:58 +0000
commit974c713a78f174f0f9c9100fe9cef9f96baa7879 (patch)
treeba3586e31d231f489bfb15b94ea3062d66e26bed /games-strategy
parentFixes for bug #106826 (added password for local connection to webserwer) and ... (diff)
downloadgentoo-2-974c713a78f174f0f9c9100fe9cef9f96baa7879.tar.gz
gentoo-2-974c713a78f174f0f9c9100fe9cef9f96baa7879.tar.bz2
gentoo-2-974c713a78f174f0f9c9100fe9cef9f96baa7879.zip
Use user-CFLAGS thanks to Christopher Covington <covracer@gmail.com> in bug 118358
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog7
-rw-r--r--games-strategy/widelands/files/widelands-makefile.patch14
-rw-r--r--games-strategy/widelands/widelands-0.0.9.5.ebuild6
3 files changed, 24 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index 8bdc3e3de934..736be962b924 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.7 2006/01/09 12:13:24 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.8 2006/01/13 13:57:58 genstef Exp $
+
+ 13 Jan 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/widelands-makefile.patch, widelands-0.0.9.5.ebuild:
+ Use user-CFLAGS thanks to Christopher Covington <covracer@gmail.com> in bug
+ 118358
09 Jan 2006; Stefan Schweizer <genstef@gentoo.org>
widelands-0.0.9.5.ebuild:
diff --git a/games-strategy/widelands/files/widelands-makefile.patch b/games-strategy/widelands/files/widelands-makefile.patch
new file mode 100644
index 000000000000..da96caf3241e
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-makefile.patch
@@ -0,0 +1,14 @@
+--- widelands-b9half/Makefile.orig 2006-01-13 00:19:12.000000000 +0100
++++ widelands-b9half/Makefile 2006-01-13 00:19:29.000000000 +0100
+@@ -160,9 +160,9 @@
+ # Object files and directories, final compilation flags
+
+ OBJECT_DIR:=src/$(TARGET)-$(BUILD)
+-CFLAGS:=-Wall $(shell $(SDL_CONFIG) --cflags) $(ADD_CFLAGS)
++CFLAGS:=-Wall $(shell $(SDL_CONFIG) --cflags) $(ADD_CFLAGS) $(CFLAGS)
+ CXXFLAGS:=$(CFLAGS)
+-LDFLAGS:=$(shell $(SDL_CONFIG) --libs) $(ADD_LDFLAGS) -lz -lpng -lSDL_image -lSDL_mixer -lSDL_ttf -lSDL_net
++LDFLAGS:=$(shell $(SDL_CONFIG) --libs) $(ADD_LDFLAGS) -lz -lpng -lSDL_image -lSDL_mixer -lSDL_ttf -lSDL_net $(LDFLAGS)
+
+ ##############################################################################
+ # Building
diff --git a/games-strategy/widelands/widelands-0.0.9.5.ebuild b/games-strategy/widelands/widelands-0.0.9.5.ebuild
index 79478ecb2e6a..e424acfdf3dd 100644
--- a/games-strategy/widelands/widelands-0.0.9.5.ebuild
+++ b/games-strategy/widelands/widelands-0.0.9.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.9.5.ebuild,v 1.6 2006/01/09 12:13:24 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.0.9.5.ebuild,v 1.7 2006/01/13 13:57:58 genstef Exp $
-inherit eutils games
+inherit eutils games flag-o-matic
DESCRIPTION="A game similar to Settlers 2"
HOMEPAGE="http://widelands.sourceforge.net/"
@@ -28,10 +28,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/widelands-0.0.9-amd64.patch"
+ epatch "${FILESDIR}/widelands-makefile.patch"
sed -i -e "s:__ppc__:__PPC__:g" "${S}/src/machdep.h" || die "sed failed"
}
src_compile() {
+ filter-flags -fomit-frame-pointer
use debug || export BUILD="release"
use elibc_glibc && export IMPLICIT_LIBINTL=1
emake || die "emake failed"