summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-03 15:51:03 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-03 15:51:03 +0000
commit586a13fa957e7591e8921a33d4cb96a1066ff4cf (patch)
tree9b5907ef99ee18631b845aff8329db35b40d6622 /games-strategy/wormux
parentStable on MIPS; bug #164176 (diff)
downloadgentoo-2-586a13fa957e7591e8921a33d4cb96a1066ff4cf.tar.gz
gentoo-2-586a13fa957e7591e8921a33d4cb96a1066ff4cf.tar.bz2
gentoo-2-586a13fa957e7591e8921a33d4cb96a1066ff4cf.zip
Version bump, bug #163903
(Portage version: 2.1.2-r6)
Diffstat (limited to 'games-strategy/wormux')
-rw-r--r--games-strategy/wormux/ChangeLog10
-rw-r--r--games-strategy/wormux/files/digest-wormux-0.7.93
-rw-r--r--games-strategy/wormux/files/wormux-0.7.9-user-CFLAGS.patch30
-rw-r--r--games-strategy/wormux/wormux-0.7.9.ebuild55
4 files changed, 96 insertions, 2 deletions
diff --git a/games-strategy/wormux/ChangeLog b/games-strategy/wormux/ChangeLog
index 675ea4a05b1e..b4596b45986a 100644
--- a/games-strategy/wormux/ChangeLog
+++ b/games-strategy/wormux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wormux
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.18 2006/11/02 04:44:19 josejx Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/ChangeLog,v 1.19 2007/02/03 15:51:03 nyhm Exp $
+
+*wormux-0.7.9 (03 Feb 2007)
+
+ 03 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/wormux-0.7.9-user-CFLAGS.patch, +wormux-0.7.9.ebuild:
+ Version bump, bug #163903
02 Nov 2006; Joseph Jezak <josejx@gentoo.org> wormux-0.7.4.ebuild:
Marked ~ppc for bug #153188.
diff --git a/games-strategy/wormux/files/digest-wormux-0.7.9 b/games-strategy/wormux/files/digest-wormux-0.7.9
new file mode 100644
index 000000000000..8c419281f04f
--- /dev/null
+++ b/games-strategy/wormux/files/digest-wormux-0.7.9
@@ -0,0 +1,3 @@
+MD5 d921ae5bad243dec7bb6825d6e0b9d16 wormux-0.7.9.tar.gz 31674094
+RMD160 4943248ab65c933f2c70908aa4b1f08705ad2a0e wormux-0.7.9.tar.gz 31674094
+SHA256 9c260c1dd3c77159ccb71a21df61dc784e875fda4a7e5741dcb22fe7a48a8282 wormux-0.7.9.tar.gz 31674094
diff --git a/games-strategy/wormux/files/wormux-0.7.9-user-CFLAGS.patch b/games-strategy/wormux/files/wormux-0.7.9-user-CFLAGS.patch
new file mode 100644
index 000000000000..4f8a1b55d593
--- /dev/null
+++ b/games-strategy/wormux/files/wormux-0.7.9-user-CFLAGS.patch
@@ -0,0 +1,30 @@
+--- configure
++++ configure
+@@ -7314,13 +7314,11 @@
+ GCC_FLAGS="$GCC_FLAGS -Wno-unused-parameter"
+
+ if test "x${debug}" = "xyes"; then
+- GCC_FLAGS="$GCC_FLAGS -O0 -g -DDEBUG"
+- else
+- GCC_FLAGS="$GCC_FLAGS -O2"
++ GCC_FLAGS="$GCC_FLAGS -DDEBUG"
+ fi
+
+- CFLAGS="$GCC_FLAGS"
+- CXXFLAGS="$GCC_FLAGS"
++ CFLAGS="$CFLAGS $GCC_FLAGS"
++ CXXFLAGS="$CXXFLAGS $GCC_FLAGS"
+
+ else
+ if test "x${debug}" = "xyes"; then
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -518,7 +518,7 @@
+ weapon/submachine_gun.h weapon/polecat.cpp weapon/polecat.h \
+ weapon/blowtorch.cpp weapon/blowtorch.h weapon/syringe.cpp \
+ weapon/syringe.h $(am__append_1)
+-AM_CXXFLAGS = -DINSTALL_DATADIR=\"$(pkgdatadir)\" -DINSTALL_LOCALEDIR=\"$(localedir)\" -DFONT_FILE=\"$(fontfile)\" -DPACKAGE_VERSION=\"$(PACKAGE_VERSION)\" -Werror
++AM_CXXFLAGS = -DINSTALL_DATADIR=\"$(pkgdatadir)\" -DINSTALL_LOCALEDIR=\"$(localedir)\" -DFONT_FILE=\"$(fontfile)\" -DPACKAGE_VERSION=\"$(PACKAGE_VERSION)\"
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
+
diff --git a/games-strategy/wormux/wormux-0.7.9.ebuild b/games-strategy/wormux/wormux-0.7.9.ebuild
new file mode 100644
index 000000000000..77ca039091b3
--- /dev/null
+++ b/games-strategy/wormux/wormux-0.7.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wormux/wormux-0.7.9.ebuild,v 1.1 2007/02/03 15:51:03 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="A free Worms clone"
+HOMEPAGE="http://www.wormux.org/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug nls"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ media-libs/sdl-gfx
+ net-misc/curl
+ >=dev-cpp/libxmlpp-2.6
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-user-CFLAGS.patch
+ sed -i \
+ -e '/^xdg_appsdir/s:$(datadir):/usr/share:' \
+ data/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-datadir-name="${GAMES_DATADIR}"/${PN} \
+ --with-localedir-name=/usr/share/locale \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon data/wormux_128x128.png
+ dodoc AUTHORS ChangeLog README TODO
+ prepgamesdirs
+}