summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-10 17:52:51 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-10 17:52:51 +0000
commitdfd2e6bc14aeeb776a4390880da4eb9e188bd9d5 (patch)
tree87314eb33377bdc5916e26218841931c0303ef52 /games-simulation/pmars-sdl
parentWebapps now require webapp-config 1.7 (diff)
downloadgentoo-2-dfd2e6bc14aeeb776a4390880da4eb9e188bd9d5.tar.gz
gentoo-2-dfd2e6bc14aeeb776a4390880da4eb9e188bd9d5.tar.bz2
gentoo-2-dfd2e6bc14aeeb776a4390880da4eb9e188bd9d5.zip
dont use $CC
Diffstat (limited to 'games-simulation/pmars-sdl')
-rw-r--r--games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
index acd1c5211e63..3920643b50e3 100644
--- a/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
+++ b/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild,v 1.2 2004/03/30 15:48:34 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/pmars-sdl/pmars-sdl-0.9.2e.ebuild,v 1.3 2004/05/10 17:52:51 vapier Exp $
-inherit games
+inherit games gcc
MY_PN="${PN/-sdl/}"
MY_PV="${PV/e/-5}"
@@ -61,16 +61,16 @@ src_compile() {
for x in ${SRC}; do
einfo "compiling ${x}"
- ${CC} ${CFLAGS} ${x} -c || die
+ $(gcc-getCC) ${CFLAGS} ${x} -c || die
done
echo
einfo "linking with LIB: ${LIB}"
- ${CC} *.o ${LIB} -o ${MY_PN} || die
+ $(gcc-getCC) *.o ${LIB} -o ${MY_PN} || die
}
src_install() {
- dogamesbin src/${MY_PN}
+ dogamesbin src/${MY_PN} || die
doman doc/${MY_PN}.6
dodoc AUTHORS CONTRIB ChangeLog README doc/redcode.ref
@@ -85,7 +85,6 @@ src_install() {
}
pkg_postinst() {
- echo
ewarn "There are some macros in ${GAMES_DATADIR}/${MY_PN}/macros"
ewarn "which you should make accessible to pmars by typing"
ewarn "export PMARSHOME=${GAMES_DATADIR}/${MY_PN}/macros\n"