summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-13 20:46:28 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-13 20:46:28 +0000
commit05f3a04ecb90d55aabbe86985fe5196b8113b3b8 (patch)
treebf98f56ca03d57ef8c5c05210cfa614c77a4f49d /games-rpg
parentStable for s390, wrt bug #459904 (diff)
downloadgentoo-2-05f3a04ecb90d55aabbe86985fe5196b8113b3b8.tar.gz
gentoo-2-05f3a04ecb90d55aabbe86985fe5196b8113b3b8.tar.bz2
gentoo-2-05f3a04ecb90d55aabbe86985fe5196b8113b3b8.zip
version bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/manaplus/ChangeLog7
-rw-r--r--games-rpg/manaplus/manaplus-1.3.4.14.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/games-rpg/manaplus/ChangeLog b/games-rpg/manaplus/ChangeLog
index 05e7f9823fde..ce5a310b2731 100644
--- a/games-rpg/manaplus/ChangeLog
+++ b/games-rpg/manaplus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/manaplus
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.4 2013/04/01 17:35:48 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/ChangeLog,v 1.5 2013/04/13 20:46:28 hasufell Exp $
+
+*manaplus-1.3.4.14 (13 Apr 2013)
+
+ 13 Apr 2013; Julian Ospald <hasufell@gentoo.org> +manaplus-1.3.4.14.ebuild:
+ version bump
*manaplus-1.3.3.31 (01 Apr 2013)
diff --git a/games-rpg/manaplus/manaplus-1.3.4.14.ebuild b/games-rpg/manaplus/manaplus-1.3.4.14.ebuild
new file mode 100644
index 000000000000..11294dc23cef
--- /dev/null
+++ b/games-rpg/manaplus/manaplus-1.3.4.14.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/manaplus/manaplus-1.3.4.14.ebuild,v 1.1 2013/04/13 20:46:28 hasufell Exp $
+
+EAPI=5
+
+inherit games
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/manaplus-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls opengl"
+
+RDEPEND="
+ >=dev-games/physfs-1.0.0
+ dev-libs/libxml2
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ net-misc/curl
+ sys-libs/zlib
+ media-libs/libpng:0
+ media-fonts/dejavu
+ >=dev-games/guichan-0.8.1[sdl]
+ media-libs/libsdl[X,opengl?,video]
+ media-libs/sdl-gfx
+ x11-apps/xmessage
+ x11-libs/libX11
+ x11-misc/xdg-utils
+ x11-misc/xsel
+ nls? ( virtual/libintl )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS/s/fonts//' \
+ data/Makefile.in || die
+
+ rm -r src/guichan || die
+}
+
+src_configure() {
+ egamesconf \
+ --without-internalguichan \
+ --localedir=/usr/share/locale \
+ --disable-manaserv \
+ --disable-eathena \
+ $(use_with opengl) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${GAMES_DATADIR}"/${PN}/data/fonts/dejavusans-mono.ttf
+ insinto "${GAMES_DATADIR}"/${PN}/data
+
+ prepgamesdirs
+}