summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-01 18:59:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-01 18:59:49 +0000
commit97d0cd8e45030c246cda9c2d37c9545d5dcd080c (patch)
treedf3308324431e7ef7e9283757fcb8870329cfecc /games-puzzle/tong/tong-1.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-97d0cd8e45030c246cda9c2d37c9545d5dcd080c.tar.gz
gentoo-2-97d0cd8e45030c246cda9c2d37c9545d5dcd080c.tar.bz2
gentoo-2-97d0cd8e45030c246cda9c2d37c9545d5dcd080c.zip
initial commit - ebuild submitted by eGore via bug #76950
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-puzzle/tong/tong-1.0.ebuild')
-rw-r--r--games-puzzle/tong/tong-1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-puzzle/tong/tong-1.0.ebuild b/games-puzzle/tong/tong-1.0.ebuild
new file mode 100644
index 000000000000..2cfe1877f673
--- /dev/null
+++ b/games-puzzle/tong/tong-1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tong/tong-1.0.ebuild,v 1.1 2005/02/01 18:59:49 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Tetris and Pong in the same place at the same time"
+HOMEPAGE="http://www.nongnu.org/tong/"
+SRC_URI="http://www.nongnu.org/tong/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+ sed -i \
+ -e "s:\"media/:\"${GAMES_DATADIR}/${PN}/media/:" \
+ media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
+ || die "sed failed"
+ cp media/icon.png "${T}/${PN}.png"
+}
+
+src_install() {
+ dogamesbin tong || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r media/ "${D}/${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc CHANGELOG README making-of.txt CREDITS
+
+ make_desktop_entry tong TONG ${PN}.png
+ doicon "${T}/${PN}.png"
+ prepgamesdirs
+}