summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-09-01 02:31:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-09-01 02:31:18 +0000
commit48aeef943504d179a7c61031172fdf8429426d4b (patch)
treedf4d8b9fe51b47367b21447e6cd46c07ab29900b /games-puzzle/shaaft
parentInitial import, ebuild by me (diff)
downloadgentoo-2-48aeef943504d179a7c61031172fdf8429426d4b.tar.gz
gentoo-2-48aeef943504d179a7c61031172fdf8429426d4b.tar.bz2
gentoo-2-48aeef943504d179a7c61031172fdf8429426d4b.zip
any mod support will do
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-puzzle/shaaft')
-rw-r--r--games-puzzle/shaaft/ChangeLog11
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch5
-rw-r--r--games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch4
-rw-r--r--games-puzzle/shaaft/shaaft-0.5.0.ebuild10
4 files changed, 17 insertions, 13 deletions
diff --git a/games-puzzle/shaaft/ChangeLog b/games-puzzle/shaaft/ChangeLog
index 37cc964874f6..3f57a02878be 100644
--- a/games-puzzle/shaaft/ChangeLog
+++ b/games-puzzle/shaaft/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/shaaft
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/shaaft/ChangeLog,v 1.13 2011/09/17 16:22:20 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/shaaft/ChangeLog,v 1.14 2012/09/01 02:31:18 mr_bones_ Exp $
+
+ 01 Sep 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ files/shaaft-0.5.0-gcc34.patch, files/shaaft-0.5.0-gcc41.patch,
+ files/shaaft-0.5.0-gcc43.patch, files/shaaft-0.5.0-libpng15.patch,
+ shaaft-0.5.0.ebuild:
+ any mod support will do
17 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> shaaft-0.5.0.ebuild,
+files/shaaft-0.5.0-libpng15.patch:
@@ -44,4 +50,3 @@
01 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
shaaft-0.5.0.ebuild:
initial commit; ebuild submitted by Chris Aniszczyk via bug 40031
-
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch
index 604eb7155652..de3d59c90771 100644
--- a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc34.patch
@@ -1,6 +1,5 @@
-diff -uprN Shaaft-0.5.0.orig/utils/HashString.hpp Shaaft-0.5.0/utils/HashString.hpp
---- Shaaft-0.5.0.orig/utils/HashString.hpp 2005-06-05 18:12:29.000000000 +0200
-+++ Shaaft-0.5.0/utils/HashString.hpp 2005-06-05 18:24:05.000000000 +0200
+--- Shaaft-0.5.0.orig/utils/HashString.hpp
++++ Shaaft-0.5.0/utils/HashString.hpp
@@ -21,6 +21,7 @@ using namespace std;
namespace HASH_NAMESPACE
diff --git a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch
index 73310a138273..87b07f109d2f 100644
--- a/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch
+++ b/games-puzzle/shaaft/files/shaaft-0.5.0-gcc41.patch
@@ -1,5 +1,5 @@
---- utils/hashMap.hpp.old 2006-05-21 13:46:38.000000000 +0200
-+++ utils/hashMap.hpp 2006-05-21 13:47:22.000000000 +0200
+--- utils/hashMap.hpp.old
++++ utils/hashMap.hpp
@@ -14,7 +14,7 @@
//
#if defined( __GNUC__ )
diff --git a/games-puzzle/shaaft/shaaft-0.5.0.ebuild b/games-puzzle/shaaft/shaaft-0.5.0.ebuild
index a5f750ce633b..b38b5459b142 100644
--- a/games-puzzle/shaaft/shaaft-0.5.0.ebuild
+++ b/games-puzzle/shaaft/shaaft-0.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/shaaft/shaaft-0.5.0.ebuild,v 1.15 2011/09/17 16:22:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/shaaft/shaaft-0.5.0.ebuild,v 1.16 2012/09/01 02:31:18 mr_bones_ Exp $
EAPI=2
inherit autotools eutils games
@@ -16,9 +16,9 @@ IUSE=""
DEPEND="virtual/opengl
sys-libs/zlib
- media-libs/libpng
+ media-libs/libpng:0
media-libs/libsdl[audio,opengl,video]
- media-libs/sdl-mixer[mikmod]
+ media-libs/sdl-mixer[mod]
media-libs/sdl-image[png]"
S=${WORKDIR}/${P/s/S}
@@ -40,7 +40,7 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc41.patch \
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-libpng15.patch
-
+ mv configure.in configure.ac || die
eautoreconf
}