summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-15 22:55:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-15 22:55:07 +0000
commit4b61ca4c784404d374e42573206f8e8cb31cc262 (patch)
tree73994a88dcf84883d6a02e1fa38c73323cf1f771 /games-kids/tuxmath
parentAdded patch to fix compilation problems for projects depending on log4cxx (bu... (diff)
downloadgentoo-2-4b61ca4c784404d374e42573206f8e8cb31cc262.tar.gz
gentoo-2-4b61ca4c784404d374e42573206f8e8cb31cc262.tar.bz2
gentoo-2-4b61ca4c784404d374e42573206f8e8cb31cc262.zip
Install menu entry, bug #160256
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-kids/tuxmath')
-rw-r--r--games-kids/tuxmath/ChangeLog5
-rw-r--r--games-kids/tuxmath/tuxmath-20010907.ebuild50
2 files changed, 31 insertions, 24 deletions
diff --git a/games-kids/tuxmath/ChangeLog b/games-kids/tuxmath/ChangeLog
index 47d6249215b7..72cefe6b88ca 100644
--- a/games-kids/tuxmath/ChangeLog
+++ b/games-kids/tuxmath/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-kids/tuxmath
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.7 2007/02/22 01:03:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/ChangeLog,v 1.8 2007/03/15 22:55:07 nyhm Exp $
+
+ 15 Mar 2007; Tristan Heaven <nyhm@gentoo.org> tuxmath-20010907.ebuild:
+ Install menu entry, bug #160256
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-kids/tuxmath/tuxmath-20010907.ebuild b/games-kids/tuxmath/tuxmath-20010907.ebuild
index f822aaab02aa..1eb4b4c9b650 100644
--- a/games-kids/tuxmath/tuxmath-20010907.ebuild
+++ b/games-kids/tuxmath/tuxmath-20010907.ebuild
@@ -1,41 +1,45 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/tuxmath-20010907.ebuild,v 1.8 2006/10/03 08:30:50 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/tuxmath/tuxmath-20010907.ebuild,v 1.9 2007/03/15 22:55:07 nyhm Exp $
-inherit games
+inherit eutils toolchain-funcs games
MY_P="${PN}-2001.09.07-0102"
DESCRIPTION="Educational arcade game where you have to solve math problems"
-SRC_URI="mirror://sourceforge/tuxmath/${MY_P}.tar.gz"
HOMEPAGE="http://www.newbreedsoftware.com/tuxmath/"
+SRC_URI="mirror://sourceforge/tuxmath/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.1.5
- >=media-libs/sdl-image-1.2.2
- >=media-libs/sdl-mixer-1.2.4"
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- emake \
- DATA_PREFIX=${GAMES_DATADIR}/${PN} \
- BIN_PREFIX=${GAMES_BINDIR} \
- || die "emake failed"
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -rf $(find -name CVS -o -name .xvpics -type d)
+ rm -f docs/COPYING.txt
+ sed -i \
+ -e '/strip/d' \
+ -e "1i CC=$(tc-getCC)" \
+ -e "s/-O2/${CFLAGS}/" \
+ -e "s:\$(DATA_PREFIX):${GAMES_DATADIR}/${PN}:" \
+ Makefile \
+ || die "sed failed"
}
src_install() {
- find -name CVS -type d -exec rm -rf '{}' \;
-
- dogamesbin tuxmath || die "dogamesbin failed"
-
- dodir "${GAMES_DATADIR}/${PN}"
- cp -r data/{images,sounds} "${D}/${GAMES_DATADIR}/${PN}/" \
- || die "cp failed"
-
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/{images,sounds} || die "doins failed"
+ newicon data/images/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Tux Math"
dodoc docs/*.txt
prepgamesdirs
}