summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-28 06:29:25 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-28 06:29:25 +0000
commit89e63648cc9965d4b624a843cfe2be6a41f914ff (patch)
tree890ec1f7703d29400beab63a8379b396858c832c /games-fps/quake1
parentMoved "app-sci/gturing" to "sci-mathematics". (diff)
downloadgentoo-2-89e63648cc9965d4b624a843cfe2be6a41f914ff.tar.gz
gentoo-2-89e63648cc9965d4b624a843cfe2be6a41f914ff.tar.bz2
gentoo-2-89e63648cc9965d4b624a843cfe2be6a41f914ff.zip
Make sure the game can find the data files #58849 by Olivier.
Diffstat (limited to 'games-fps/quake1')
-rw-r--r--games-fps/quake1/ChangeLog10
-rw-r--r--games-fps/quake1/files/digest-quake1-2.40-r1 (renamed from games-fps/quake1/files/digest-quake1-2.40)0
-rw-r--r--games-fps/quake1/files/gentoo-paths.patch32
-rw-r--r--games-fps/quake1/files/makefile-cflags.patch (renamed from games-fps/quake1/files/makefile-gcc3-cflags.patch)8
-rw-r--r--games-fps/quake1/files/makefile-gcc2-cflags.patch16
-rw-r--r--games-fps/quake1/quake1-2.40-r1.ebuild (renamed from games-fps/quake1/quake1-2.40.ebuild)20
6 files changed, 55 insertions, 31 deletions
diff --git a/games-fps/quake1/ChangeLog b/games-fps/quake1/ChangeLog
index 78f91219d4e7..97ccc56739da 100644
--- a/games-fps/quake1/ChangeLog
+++ b/games-fps/quake1/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-fps/quake1
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/ChangeLog,v 1.5 2004/11/20 09:33:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/ChangeLog,v 1.6 2004/12/28 06:29:25 vapier Exp $
+
+*quake1-2.40-r1 (28 Dec 2004)
+
+ 28 Dec 2004; Mike Frysinger <vapier@gentoo.org> +files/gentoo-paths.patch,
+ +files/makefile-cflags.patch, -files/makefile-gcc2-cflags.patch,
+ -files/makefile-gcc3-cflags.patch, +quake1-2.40-r1.ebuild,
+ -quake1-2.40.ebuild:
+ Make sure the game can find the data files #58849 by Olivier.
20 Nov 2004; Michael Sterrett <mr_bones_@gentoo.org> quake1-2.40.ebuild:
tidy; error check
diff --git a/games-fps/quake1/files/digest-quake1-2.40 b/games-fps/quake1/files/digest-quake1-2.40-r1
index 7f6e600a9e1d..7f6e600a9e1d 100644
--- a/games-fps/quake1/files/digest-quake1-2.40
+++ b/games-fps/quake1/files/digest-quake1-2.40-r1
diff --git a/games-fps/quake1/files/gentoo-paths.patch b/games-fps/quake1/files/gentoo-paths.patch
new file mode 100644
index 000000000000..e54b0a42242b
--- /dev/null
+++ b/games-fps/quake1/files/gentoo-paths.patch
@@ -0,0 +1,32 @@
+--- WinQuake/common.c.orig 2004-12-28 01:13:18.982915064 -0500
++++ WinQuake/common.c 2004-12-28 01:16:01.038278904 -0500
+@@ -1775,11 +1775,16 @@
+ // start up with GAMENAME by default (id1)
+ //
+ COM_AddGameDirectory (va("%s/"GAMENAME, basedir) );
++ COM_AddGameDirectory (va("GENTOO_DATADIR/"GAMENAME) );
+
+- if (COM_CheckParm ("-rogue"))
++ if (COM_CheckParm ("-rogue")) {
+ COM_AddGameDirectory (va("%s/rogue", basedir) );
+- if (COM_CheckParm ("-hipnotic"))
++ COM_AddGameDirectory (va("GENTOO_DATADIR/rogue") );
++ }
++ if (COM_CheckParm ("-hipnotic")) {
+ COM_AddGameDirectory (va("%s/hipnotic", basedir) );
++ COM_AddGameDirectory (va("GENTOO_DATADIR/hipnotic") );
++ }
+
+ //
+ // -game <gamedir>
+--- QW/client/common.c.orig 2004-12-28 01:20:42.280523584 -0500
++++ QW/client/common.c 2004-12-28 01:21:14.960555464 -0500
+@@ -1845,6 +1845,8 @@
+ //
+ COM_AddGameDirectory (va("%s/id1", com_basedir) );
+ COM_AddGameDirectory (va("%s/qw", com_basedir) );
++ COM_AddGameDirectory (va("GENTOO_DATADIR/id1", com_basedir) );
++ COM_AddGameDirectory (va("GENTOO_DATADIR/qw", com_basedir) );
+
+ // any set gamedirs will be freed up to here
+ com_base_searchpaths = com_searchpaths;
diff --git a/games-fps/quake1/files/makefile-gcc3-cflags.patch b/games-fps/quake1/files/makefile-cflags.patch
index 136c7a937fb6..9829ba7ffbfe 100644
--- a/games-fps/quake1/files/makefile-gcc3-cflags.patch
+++ b/games-fps/quake1/files/makefile-cflags.patch
@@ -3,16 +3,14 @@
@@ -39,3 +39,3 @@
BASE_CFLAGS=-Dstricmp=strcasecmp
-RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS \
-fomit-frame-pointer -fexpensive-optimizations
--- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
+++ QW/Makefile 2003-07-14 15:15:41.000000000 -0400
-@@ -45,5 +45,5 @@
+@@ -45,5 +45,3 @@
else
-RELEASE_CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
- -malign-jumps=2 -malign-functions=2
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
-+ -fomit-frame-pointer -fexpensive-optimizations -falign-loops=2 \
-+ -falign-jumps=2 -falign-functions=2
++RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS
endif
diff --git a/games-fps/quake1/files/makefile-gcc2-cflags.patch b/games-fps/quake1/files/makefile-gcc2-cflags.patch
deleted file mode 100644
index 3b2f87df4080..000000000000
--- a/games-fps/quake1/files/makefile-gcc2-cflags.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
-+++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
-@@ -39,3 +39,3 @@
- BASE_CFLAGS=-Dstricmp=strcasecmp
--RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations
---- QW/Makefile.orig 2003-07-14 15:13:12.000000000 -0400
-+++ QW/Makefile 2003-07-14 15:15:41.000000000 -0400
-@@ -44,5 +44,5 @@
- -fomit-frame-pointer -fexpensive-optimizations
- else
--RELEASE_CFLAGS=$(BASE_CFLAGS) -m486 -O6 -ffast-math -funroll-loops \
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations -malign-loops=2 \
- -malign-jumps=2 -malign-functions=2
diff --git a/games-fps/quake1/quake1-2.40.ebuild b/games-fps/quake1/quake1-2.40-r1.ebuild
index a48411c2dc0b..bf334d14ac25 100644
--- a/games-fps/quake1/quake1-2.40.ebuild
+++ b/games-fps/quake1/quake1-2.40-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40.ebuild,v 1.7 2004/11/20 09:33:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1/quake1-2.40-r1.ebuild,v 1.1 2004/12/28 06:29:25 vapier Exp $
inherit eutils gcc games
@@ -32,21 +32,23 @@ pkg_setup() {
src_unpack() {
unpack ${A}
- epatch "${FILESDIR}/fix-sys_printf.patch"
+ epatch "${FILESDIR}"/fix-sys_printf.patch
mv WinQuake/Makefile{.linuxi386,}
mv QW/Makefile{.Linux,}
- epatch "${FILESDIR}/makefile-path-fixes.patch"
+ epatch "${FILESDIR}"/makefile-path-fixes.patch
+ epatch "${FILESDIR}"/gentoo-paths.patch
+ sed -i -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/quake-data:" \
+ {QW/client,WinQuake}/common.c || die "setting data paths"
- [ $(gcc-major-version) -eq 3 ] \
- && epatch "${FILESDIR}/makefile-gcc3-cflags.patch" \
- || epatch "${FILESDIR}/makefile-gcc2-cflags.patch"
+ epatch "${FILESDIR}"/makefile-cflags.patch
sed -i "s:GENTOO_CFLAGS:${CFLAGS} -DGL_EXT_SHARED=1:" {WinQuake,QW}/Makefile
+
cp QW/client/glquake.h{,.orig}
(echo "#define APIENTRY";cat QW/client/glquake.h.orig) > QW/client/glquake.h
- epatch "${FILESDIR}/makefile-sedable.patch"
+ epatch "${FILESDIR}"/makefile-sedable.patch
if ! use 3dfx ; then
sed -i 's:^ $(BUILDDIR)/bin/glquake ::' WinQuake/Makefile
sed -i 's:^ $(BUILDDIR)/bin/glquake.3dfxgl ::' WinQuake/Makefile
@@ -67,8 +69,8 @@ src_unpack() {
}
src_compile() {
- make -C "${S}/WinQuake" build_release || die "failed to build WinQuake"
- make -C "${S}/QW" build_release || die "failed to build QW"
+ emake -j1 -C "${S}"/WinQuake build_release || die "failed to build WinQuake"
+ emake -j1 -C "${S}"/QW build_release || die "failed to build QW"
}
src_install() {