summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2013-08-27 01:29:10 +0000
committerDevan Franchini <twitch153@gentoo.org>2013-08-27 01:29:10 +0000
commit2ae91ed034e62ff5edf2c91aaaaa6c96a96f7159 (patch)
tree1584fcaa960d3559c2d576fcb8e746aba994a445 /games-emulation
parentversion bump (diff)
downloadgentoo-2-2ae91ed034e62ff5edf2c91aaaaa6c96a96f7159.tar.gz
gentoo-2-2ae91ed034e62ff5edf2c91aaaaa6c96a96f7159.tar.bz2
gentoo-2-2ae91ed034e62ff5edf2c91aaaaa6c96a96f7159.zip
dolphin-3.5.ebuild: Adds check for binary package to prevent unnecessary checking of gcc-version
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin/ChangeLog6
-rw-r--r--games-emulation/dolphin/dolphin-3.5.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/games-emulation/dolphin/ChangeLog b/games-emulation/dolphin/ChangeLog
index 7a8028f5dc2b..60a09930a53f 100644
--- a/games-emulation/dolphin/ChangeLog
+++ b/games-emulation/dolphin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.4 2013/08/26 18:09:23 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.5 2013/08/27 01:29:10 twitch153 Exp $
+
+ 27 Aug 2013; Devan Franchini <twitch153@gentoo.org> dolphin-3.5.ebuild:
+ dolphin-3.5.ebuild: Adds check for binary package to prevent unnecessary
+ checking of gcc-version
26 Aug 2013; Devan Franchini <twitch153@gentoo.org> dolphin-3.5.ebuild,
dolphin-9999.ebuild:
diff --git a/games-emulation/dolphin/dolphin-3.5.ebuild b/games-emulation/dolphin/dolphin-3.5.ebuild
index 7230a02f5acc..6760ae425568 100644
--- a/games-emulation/dolphin/dolphin-3.5.ebuild
+++ b/games-emulation/dolphin/dolphin-3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-3.5.ebuild,v 1.4 2013/08/26 18:09:23 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-3.5.ebuild,v 1.5 2013/08/27 01:29:10 twitch153 Exp $
EAPI=5
@@ -50,9 +50,11 @@ pkg_pretend() {
local ver=4.6.0
local msg="${PN} needs at least GCC ${ver} set to compile."
- if ! version_is_at_least ${ver} $(gcc-fullversion); then
- eerror ${msg}
- die ${msg}
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ eerror ${msg}
+ die ${msg}
+ fi
fi
}