summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-02 18:35:17 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-02 18:35:17 +0000
commitafcfe40a6bdc360b5f0a7939df5be9f619f028d3 (patch)
tree55e75520b5983d3f743c2859bc04e5594e9e5c54 /games-emulation/hugo
parentstable bump for x86 (diff)
downloadgentoo-2-afcfe40a6bdc360b5f0a7939df5be9f619f028d3.tar.gz
gentoo-2-afcfe40a6bdc360b5f0a7939df5be9f619f028d3.tar.bz2
gentoo-2-afcfe40a6bdc360b5f0a7939df5be9f619f028d3.zip
Fix emerge with gcc-4.1
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-emulation/hugo')
-rw-r--r--games-emulation/hugo/ChangeLog6
-rw-r--r--games-emulation/hugo/files/digest-hugo-2.122
-rw-r--r--games-emulation/hugo/files/hugo-2.12-gcc41.patch11
-rw-r--r--games-emulation/hugo/hugo-2.12.ebuild10
4 files changed, 26 insertions, 3 deletions
diff --git a/games-emulation/hugo/ChangeLog b/games-emulation/hugo/ChangeLog
index f6f7ab20aec1..9663d5870693 100644
--- a/games-emulation/hugo/ChangeLog
+++ b/games-emulation/hugo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/hugo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/ChangeLog,v 1.5 2006/02/10 19:58:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/ChangeLog,v 1.6 2006/05/02 18:35:17 tupone Exp $
+
+ 02 May 2006; <Tupone@gentoo.org> +files/hugo-2.12-gcc41.patch,
+ hugo-2.12.ebuild:
+ Fixing gcc-4.1 compilation
10 Feb 2006; Chris Gianelloni <wolf31o2@gentoo.org> -hugo-2.09.ebuild,
hugo-2.12.ebuild:
diff --git a/games-emulation/hugo/files/digest-hugo-2.12 b/games-emulation/hugo/files/digest-hugo-2.12
index 30c791139451..ae7777f69a6c 100644
--- a/games-emulation/hugo/files/digest-hugo-2.12
+++ b/games-emulation/hugo/files/digest-hugo-2.12
@@ -1 +1,3 @@
MD5 1256ab47592413d12789166da23c00fc hugo-2.12.tar.gz 456991
+RMD160 9d2046d854cdc33da35a3b9f5374e90efd5ee973 hugo-2.12.tar.gz 456991
+SHA256 0bc1d0a6c7d8a0906c25611cbc9fb391afb59770c0cd71a7329b1338c1821b8e hugo-2.12.tar.gz 456991
diff --git a/games-emulation/hugo/files/hugo-2.12-gcc41.patch b/games-emulation/hugo/files/hugo-2.12-gcc41.patch
new file mode 100644
index 000000000000..14050cc79f16
--- /dev/null
+++ b/games-emulation/hugo/files/hugo-2.12-gcc41.patch
@@ -0,0 +1,11 @@
+--- pce.h.old 2006-05-02 20:06:13.000000000 +0200
++++ pce.h 2006-05-02 20:06:33.000000000 +0200
+@@ -196,7 +196,7 @@
+ extern UChar language;
+ // the current language
+
+-extern int BaseClock, UPeriod;
++extern int UPeriod;
+
+ extern UChar US_encoded_card;
+ // Do we have to swap even and odd bytes in the rom
diff --git a/games-emulation/hugo/hugo-2.12.ebuild b/games-emulation/hugo/hugo-2.12.ebuild
index 0e1c063f069f..ccd84f518f0f 100644
--- a/games-emulation/hugo/hugo-2.12.ebuild
+++ b/games-emulation/hugo/hugo-2.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/hugo-2.12.ebuild,v 1.2 2006/02/10 19:58:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/hugo-2.12.ebuild,v 1.3 2006/05/02 18:35:17 tupone Exp $
-inherit games
+inherit eutils games
DESCRIPTION="PC-Engine (Turbografx16) emulator for linux"
HOMEPAGE="http://www.zeograd.com/"
@@ -17,6 +17,12 @@ RDEPEND="x11-libs/gtk+
media-libs/libsdl
media-libs/libvorbis"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+}
+
src_install() {
dogamesbin hugo || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}"