summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDevan Franchini <twitch153@gentoo.org>2013-08-26 07:19:36 +0000
committerDevan Franchini <twitch153@gentoo.org>2013-08-26 07:19:36 +0000
commit9572ece96c36283ee5dda7343e851a39f1c6b982 (patch)
tree27e202405697555390ea80313d95743857fee48f /games-emulation/dolphin
parentVersion bump. (diff)
downloadgentoo-2-9572ece96c36283ee5dda7343e851a39f1c6b982.tar.gz
gentoo-2-9572ece96c36283ee5dda7343e851a39f1c6b982.tar.bz2
gentoo-2-9572ece96c36283ee5dda7343e851a39f1c6b982.zip
Added pkg_pretend() function to check for gcc version instead of src_prepare() in both ebuilds; also fixes keywording issues in 9999 ebuild
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'games-emulation/dolphin')
-rw-r--r--games-emulation/dolphin/ChangeLog7
-rw-r--r--games-emulation/dolphin/dolphin-3.5.ebuild15
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild19
3 files changed, 32 insertions, 9 deletions
diff --git a/games-emulation/dolphin/ChangeLog b/games-emulation/dolphin/ChangeLog
index dc39f48315a9..d2eb0096e00b 100644
--- a/games-emulation/dolphin/ChangeLog
+++ b/games-emulation/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dolphin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.1 2013/08/26 04:25:00 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/ChangeLog,v 1.2 2013/08/26 07:19:36 twitch153 Exp $
+
+ 26 Aug 2013; Devan Franchini <twitch153@gentoo.org> dolphin-3.5.ebuild,
+ dolphin-9999.ebuild:
+ Added pkg_pretend() function to check for gcc version instead of src_prepare()
+ in both ebuilds; also fixes keywording issues in 9999 ebuild
*dolphin-9999 (26 Aug 2013)
*dolphin-3.5 (26 Aug 2013)
diff --git a/games-emulation/dolphin/dolphin-3.5.ebuild b/games-emulation/dolphin/dolphin-3.5.ebuild
index 71612b53ed25..cf26a70fbb03 100644
--- a/games-emulation/dolphin/dolphin-3.5.ebuild
+++ b/games-emulation/dolphin/dolphin-3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-3.5.ebuild,v 1.1 2013/08/26 04:24:59 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-3.5.ebuild,v 1.2 2013/08/26 07:19:36 twitch153 Exp $
EAPI=5
@@ -45,9 +45,18 @@ DEPEND="${RDEPEND}
x11-libs/wxGTK:2.9
"
-src_prepare() {
+pkg_pretend() {
+
+ local ver=4.6.0
+ local msg="${PN} needs at least GCC ${ver} set to compile."
+
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
- version_is_at_least 4.6.0 $(gcc-fullversion) || die "${PN} needs >=gcc-4.6.0 set to compile."
+src_prepare() {
if has_version "=sys-devel/gcc-4.8.0"; then
epatch "${FILESDIR}"/${PN}-emu-${PV}-gcc-4.8.patch
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index 21e9911f70d6..8453cd49fbdc 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.1 2013/08/26 04:24:59 twitch153 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dolphin/dolphin-9999.ebuild,v 1.2 2013/08/26 07:19:36 twitch153 Exp $
EAPI=5
@@ -12,10 +12,10 @@ if [[ ${PV} == 9999* ]]
then
EGIT_REPO_URI="https://code.google.com/p/dolphin-emu/"
inherit git-2
- KEYWORKD=""
+ KEYWORDS=""
else
SRC_URI="http://${PN}-emu.googlecode.com/files/${P}-src.zip"
- KEYWORDS="~amd"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Dolphin is a Gamecube and Wii game emulator"
@@ -51,9 +51,18 @@ DEPEND="${RDEPEND}
x11-libs/wxGTK:2.9
"
-src_prepare() {
+pkg_pretend() {
+
+ local ver=4.6.0
+ local msg="${PN} needs at least GCC ${ver} set to compile."
+
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ eerror ${msg}
+ die ${msg}
+ fi
+}
- version_is_at_least 4.6.0 $(gcc-fullversion) || die "${PN} needs >=gcc-4.6.0 set to compile."
+src_prepare() {
# Remove automatic dependencies to prevent building without flags enabled.
if use !alsa; then