summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-11 00:57:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-11 00:57:01 +0000
commitcfecc2ee37888e685e741fc8d13a20f9d29fb619 (patch)
treed60211ecaacd642b6c20892ad9a791f15b635321 /games-emulation/darcnes/darcnes-0401-r2.ebuild
parentprune extra ebuilds (Manifest recommit) (diff)
downloadgentoo-2-cfecc2ee37888e685e741fc8d13a20f9d29fb619.tar.gz
gentoo-2-cfecc2ee37888e685e741fc8d13a20f9d29fb619.tar.bz2
gentoo-2-cfecc2ee37888e685e741fc8d13a20f9d29fb619.zip
again with the use fun and games
Diffstat (limited to 'games-emulation/darcnes/darcnes-0401-r2.ebuild')
-rw-r--r--games-emulation/darcnes/darcnes-0401-r2.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-emulation/darcnes/darcnes-0401-r2.ebuild b/games-emulation/darcnes/darcnes-0401-r2.ebuild
index bb08aca6fb1a..759235d1bd12 100644
--- a/games-emulation/darcnes/darcnes-0401-r2.ebuild
+++ b/games-emulation/darcnes/darcnes-0401-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.2 2004/05/10 21:40:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/darcnes/darcnes-0401-r2.ebuild,v 1.3 2004/05/11 00:57:01 mr_bones_ Exp $
inherit games
@@ -14,6 +14,7 @@ KEYWORDS="x86 -ppc"
IUSE="gtk svga X"
DEPEND="svga? ( >=media-libs/svgalib-1.4.2 )
+ !svga? ( virtual/x11 )
X? ( virtual/x11 )
gtk? (
virtual/x11
@@ -30,21 +31,21 @@ src_compile() {
emake BINFILE=gdarcnes TARGET=Linux_GTK OPTFLAGS="${CFLAGS}" || \
die "compile target Linux_GTK failed"
fi
- if use X ; then
+ if use X || use !svga && use !gtk ; then
emake TARGET=Linux_X OPTFLAGS="${CFLAGS}" || \
die "compile target Linux_X failed"
fi
}
src_install() {
- if use X ; then
- dogamesbin darcnes || die "dogamesbin failed"
+ if use svga ; then
+ dogamesbin sdarcnes || die "dogamesbin failed (svga)"
fi
if use gtk ; then
dogamesbin gdarcnes || die "dogamesbin failed (gtk)"
fi
- if use svga ; then
- dogamesbin sdarcnes || die "dogamesbin failed (svga)"
+ if use X || use !svga && use !gtk ; then
+ dogamesbin darcnes || die "dogamesbin failed"
fi
dodoc readme
prepgamesdirs