summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-16 07:12:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-16 07:12:39 +0000
commit38f958060e884c0f4a754bb1e3760da1299346b2 (patch)
tree764433591f7f9c41cbc9d3baaeebe19aadd3cb6d /games-board
parentVersion bump. (diff)
downloadgentoo-2-38f958060e884c0f4a754bb1e3760da1299346b2.tar.gz
gentoo-2-38f958060e884c0f4a754bb1e3760da1299346b2.tar.bz2
gentoo-2-38f958060e884c0f4a754bb1e3760da1299346b2.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/scid/ChangeLog10
-rw-r--r--games-board/scid/files/scid-4.0-gentoo.patch87
-rw-r--r--games-board/scid/scid-4.0.ebuild85
3 files changed, 180 insertions, 2 deletions
diff --git a/games-board/scid/ChangeLog b/games-board/scid/ChangeLog
index 6152cbdb0106..36d89ba6f94f 100644
--- a/games-board/scid/ChangeLog
+++ b/games-board/scid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/scid
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.17 2008/07/04 06:33:16 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.18 2009/10/16 07:12:38 mr_bones_ Exp $
+
+*scid-4.0 (16 Oct 2009)
+
+ 16 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> +scid-4.0.ebuild,
+ +files/scid-4.0-gentoo.patch:
+ version bump
*scid-3.6.24 (04 Jul 2008)
diff --git a/games-board/scid/files/scid-4.0-gentoo.patch b/games-board/scid/files/scid-4.0-gentoo.patch
new file mode 100644
index 000000000000..81e50cbc8496
--- /dev/null
+++ b/games-board/scid/files/scid-4.0-gentoo.patch
@@ -0,0 +1,87 @@
+diff -ru scid.orig/engines/togaII1.2.1a/src/Makefile scid/engines/togaII1.2.1a/src/Makefile
+--- scid.orig/engines/togaII1.2.1a/src/Makefile 2009-07-08 04:28:03.000000000 -0400
++++ scid/engines/togaII1.2.1a/src/Makefile 2009-10-16 02:55:19.130622645 -0400
+@@ -16,26 +16,6 @@
+ clean:
+ $(RM) *.o .depend gmon.out fruit togaII
+
+-# general
+-
+-CXX = g++
+-CXXFLAGS = -pipe -Wall
+-LDFLAGS = -lm
+-
+-# C++
+-
+-CXXFLAGS += -fno-exceptions -fno-rtti
+-
+-# optimisation
+-
+-CXXFLAGS += -O3 -fstrict-aliasing
+-CXXFLAGS += -fomit-frame-pointer
+-# CXXFLAGS += -march=athlon-xp # SELECT ME
+-
+-# strip
+-
+-LDFLAGS += -s
+-
+ # dependencies
+
+ $(EXE): $(OBJS)
+diff -ru scid.orig/src/scidlet.cpp scid/src/scidlet.cpp
+--- scid.orig/src/scidlet.cpp 2009-01-06 03:02:08.000000000 -0500
++++ scid/src/scidlet.cpp 2009-10-16 02:58:56.289745835 -0400
+@@ -232,7 +232,7 @@
+ };
+
+ const configT defaultConfig = {
+- (char *) "scidlet.sbk", // bookFileName
++ (char *) "@GENTOO_DATADIR@/scidlet.sbk", // bookFileName
+ (char *) "scidlet.log", // logFileName
+ 16, // hashTableMB
+ 1, // pawnTableMB
+diff -ru scid.orig/tcl/config.tcl scid/tcl/config.tcl
+--- scid.orig/tcl/config.tcl 2008-05-05 03:04:12.000000000 -0400
++++ scid/tcl/config.tcl 2009-10-16 02:56:10.800616475 -0400
+@@ -5,7 +5,7 @@
+ if {$windowsOS} {
+ set scidShareDir $scidExeDir
+ } else {
+- set scidShareDir [file normalize [file join $scidExeDir "../share/scid"]]
++ set scidShareDir "@GENTOO_DATADIR@"
+ }
+
+ if {![info exists scidBooksDir]} {
+diff -ru scid.orig/tcl/start.tcl scid/tcl/start.tcl
+--- scid.orig/tcl/start.tcl 2009-08-25 03:32:55.000000000 -0400
++++ scid/tcl/start.tcl 2009-10-16 02:57:53.763745315 -0400
+@@ -922,7 +922,7 @@
+
+ ### Audio move announcement options:
+
+-set ::utils::sound::soundFolder [file nativename [file join $::scidExeDir sounds]]
++set ::utils::sound::soundFolder "@GENTOO_DATADIR@/sounds"
+ set ::utils::sound::announceNew 0
+ set ::utils::sound::announceForward 0
+ set ::utils::sound::announceBack 0
+@@ -931,7 +931,7 @@
+ if {$windowsOS} {
+ set spellCheckFile [file join $scidDataDir "spelling.ssp"]
+ } else {
+- set spellCheckFile "/usr/local/share/scid/spelling.ssp"
++ set spellCheckFile "@GENTOO_DATADIR@/spelling.ssp"
+ }
+
+ # book configuration
+diff -ru scid.orig/tcl/utils/sound.tcl scid/tcl/utils/sound.tcl
+--- scid.orig/tcl/utils/sound.tcl 2009-08-23 06:08:39.000000000 -0400
++++ scid/tcl/utils/sound.tcl 2009-10-16 02:56:32.590882174 -0400
+@@ -41,7 +41,7 @@
+ variable soundFolder
+
+ ::splash::add "Setting up audio move announcement..."
+- if {[catch {package require snack 2.0}]} {
++ if {[catch {package require snack}]} {
+ set hasSnackPackage 0
+ ::splash::add " Move speech disabled - Snack sound package not found"
+ return
diff --git a/games-board/scid/scid-4.0.ebuild b/games-board/scid/scid-4.0.ebuild
new file mode 100644
index 000000000000..4d12af227471
--- /dev/null
+++ b/games-board/scid/scid-4.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-4.0.ebuild,v 1.1 2009/10/16 07:12:38 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}.tar.bz2
+ mirror://sourceforge/scid/spelling_2009_01.ssp.zip
+ mirror://sourceforge/scid/ratings_2009_01.ssp.zip
+ mirror://sourceforge/scid/photos2007.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tk-8.3
+ >=sys-libs/zlib-1.1.3
+ app-arch/unzip"
+RDEPEND="${DEPEND}
+ !games-board/chessdb
+ x11-libs/libX11
+ >=dev-lang/python-2.1"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ tcl/config.tcl \
+ tcl/start.tcl \
+ src/scidlet.cpp \
+ || die "sed failed"
+ gzip ../ratings_2009_01.ssp
+}
+
+src_configure() {
+ # configure is not an autotools script
+ ./configure \
+ COMPILE=$(tc-getCXX) \
+ LINK=$(tc-getCXX) \
+ CC=$(tc-getCC) \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE="" \
+ BINDIR="${GAMES_BINDIR}" \
+ SHAREDIR="${GAMES_DATADIR}/${PN}" \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake all_scid || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install_scid || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds || die "failed installing sounds"
+
+ dodoc CHANGES ChangeLog README THANKS TODO
+ dohtml help/*.html
+
+ cd ..
+ newins spelling_2009_01.ssp spelling.ssp \
+ || die "Failed installing spelling.ssp"
+ newins ratings_2009_01.ssp.gz ratings.ssp.gz \
+ || die "Failed installing ratings.ssp"
+ doins *.spf \
+ || die "Failed installing photos"
+ newins scidlet40k.sbk scidlet.sbk \
+ || die "Failed installing scidlet.sbk"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To enable speech, emerge dev-tcltk/snack"
+ elog "To enable some piece sets, emerge dev-tcltk/tkimg"
+ elog "To enable Xfcc support, emerge dev-tcltk/tdom"
+}