summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-27 06:38:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-27 06:38:21 +0000
commit62386f601a5b602565d75154f8ccbd80015b0195 (patch)
tree3465902edf80b9c52686a3dc909703f7415486dc /games-board/tetzle
parentInitial import. (diff)
downloadgentoo-2-62386f601a5b602565d75154f8ccbd80015b0195.tar.gz
gentoo-2-62386f601a5b602565d75154f8ccbd80015b0195.tar.bz2
gentoo-2-62386f601a5b602565d75154f8ccbd80015b0195.zip
version bump (bug #452256)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/tetzle')
-rw-r--r--games-board/tetzle/ChangeLog10
-rw-r--r--games-board/tetzle/tetzle-2.0.1.ebuild56
2 files changed, 63 insertions, 3 deletions
diff --git a/games-board/tetzle/ChangeLog b/games-board/tetzle/ChangeLog
index 2903e5342b75..5d3d33ce88e2 100644
--- a/games-board/tetzle/ChangeLog
+++ b/games-board/tetzle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/tetzle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/tetzle/ChangeLog,v 1.5 2012/03/09 10:10:27 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/tetzle/ChangeLog,v 1.6 2013/01/27 06:38:21 mr_bones_ Exp $
+
+*tetzle-2.0.1 (27 Jan 2013)
+
+ 27 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> +tetzle-2.0.1.ebuild:
+ version bump (bug #452256)
09 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> tetzle-2.0.0.ebuild:
x86 stable wrt bug #405215
@@ -20,4 +25,3 @@
05 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +tetzle-1.2.1.ebuild:
Initial commit.
-
diff --git a/games-board/tetzle/tetzle-2.0.1.ebuild b/games-board/tetzle/tetzle-2.0.1.ebuild
new file mode 100644
index 000000000000..72cbe33b7e99
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/tetzle/tetzle-2.0.1.ebuild,v 1.1 2013/01/27 06:38:21 mr_bones_ Exp $
+
+EAPI=2
+inherit qt4-r2 gnome2-utils games
+
+DESCRIPTION="A jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="http://gottcode.org/tetzle/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-opengl-4.7:4"
+
+DOCS="ChangeLog CREDITS"
+
+src_prepare() {
+ sed -i \
+ -e "s:appdir + \"/../share/\":\"${GAMES_DATADIR}/\":" \
+ src/locale_dialog.cpp || die
+ sed -i \
+ -e "/qm.path/s:\$\$PREFIX/share:${GAMES_DATADIR}:" \
+ ${PN}.pro || die
+ sed -i \
+ -e '/Categories/s/$/;/' \
+ data/unix/tetzle.desktop || die
+}
+
+src_configure() {
+ eqmake4 BINDIR="${GAMES_BINDIR/\/usr}" PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+