summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-08 17:08:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-08 17:08:40 +0000
commit1e0e4e28c5f5b1f0e7a7c7534fe6a0f696ef7d92 (patch)
tree5b15ea818caecbc9282db989572e691781ffccfc /games-board/pysolfc
parentadd amqp use flag (bug #516704) (diff)
downloadgentoo-2-1e0e4e28c5f5b1f0e7a7c7534fe6a0f696ef7d92.tar.gz
gentoo-2-1e0e4e28c5f5b1f0e7a7c7534fe6a0f696ef7d92.tar.bz2
gentoo-2-1e0e4e28c5f5b1f0e7a7c7534fe6a0f696ef7d92.zip
old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/pysolfc')
-rw-r--r--games-board/pysolfc/ChangeLog5
-rw-r--r--games-board/pysolfc/pysolfc-2.0-r2.ebuild89
2 files changed, 4 insertions, 90 deletions
diff --git a/games-board/pysolfc/ChangeLog b/games-board/pysolfc/ChangeLog
index 406a83339fa9..749e42c50b1f 100644
--- a/games-board/pysolfc/ChangeLog
+++ b/games-board/pysolfc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/pysolfc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.21 2014/07/08 16:48:48 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.22 2014/07/08 17:08:40 mr_bones_ Exp $
+
+ 08 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> -pysolfc-2.0-r2.ebuild:
+ old
08 Jul 2014; Chema Alonso <nimiux@gentoo.org> pysolfc-2.0-r3.ebuild:
Stable for amd64 wrt bug #510776
diff --git a/games-board/pysolfc/pysolfc-2.0-r2.ebuild b/games-board/pysolfc/pysolfc-2.0-r2.ebuild
deleted file mode 100644
index a175ed79f092..000000000000
--- a/games-board/pysolfc/pysolfc-2.0-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0-r2.ebuild,v 1.7 2013/12/24 12:52:55 ago Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_6 python2_7 )
-PYTHON_REQ_USE="tk"
-
-inherit eutils python-r1 distutils-r1 games
-
-MY_PN=PySolFC
-SOL_URI="mirror://sourceforge/${PN}"
-
-DESCRIPTION="An exciting collection of more than 1000 solitaire card games"
-HOMEPAGE="http://pysolfc.sourceforge.net/"
-SRC_URI="${SOL_URI}/${MY_PN}-${PV}.tar.bz2
- extra-cardsets? ( ${SOL_URI}/${MY_PN}-Cardsets-${PV}.tar.bz2 )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="extra-cardsets minimal +sound"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-DEPEND="dev-lang/python-exec:0[${PYTHON_USEDEP}]"
-RDEPEND="${RDEPEND}
- sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
- !minimal? ( dev-python/pillow[tk,${PYTHON_USEDEP}]
- dev-tcltk/tktable )"
-
-# disable python-exec:2 support, because it is broken wrt #489646
-_PYTHON_WANT_PYTHON_EXEC2=0
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}/${PN}-PIL-imports.patch" #471514
- )
- distutils-r1_python_prepare_all
-
- sed -i \
- -e "/pysol.desktop/d" \
- -e "s:share/icons:share/pixmaps:" \
- -e "s:data_dir =.*:data_dir = \'${GAMES_DATADIR}/${PN}\':" \
- setup.py || die
-
- # avoid installing pysol.py into /usr/bin
- sed -i \
- -e '/scripts/d' \
- setup.py || die
-}
-
-src_prepare() {
- distutils-r1_src_prepare
-}
-
-src_compile() {
- distutils-r1_src_compile
-}
-
-python_install_all() {
- exeinto "${GAMES_DATADIR}"/${PN}
- doexe pysol.py
- python_replicate_script "${ED}${GAMES_DATADIR}"/${PN}/pysol.py
-
- games_make_wrapper ${PN} ./pysol.py "${GAMES_DATADIR}"/${PN}
-
- make_desktop_entry ${PN} "PySol Fan Club Edition" pysol01
-
- if use extra-cardsets; then
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${WORKDIR}"/${MY_PN}-Cardsets-${PV}/*
- fi
-
- doman docs/*.6
- dohtml docs/*.html
-
- dodoc AUTHORS README
-
- docinto docs
- dodoc docs/README*
-
- prepgamesdirs
-}
-
-src_install() {
- distutils-r1_src_install
-}