summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-02-02 19:19:26 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-02-02 19:19:26 +0000
commitd205ca9383cd3de809c63261cef480cd25645bf7 (patch)
tree294873a29102b76a0c07b90268f23da9a5446246 /games-arcade/xboing
parentVersion bump, drop old (diff)
downloadgentoo-2-d205ca9383cd3de809c63261cef480cd25645bf7.tar.gz
gentoo-2-d205ca9383cd3de809c63261cef480cd25645bf7.tar.bz2
gentoo-2-d205ca9383cd3de809c63261cef480cd25645bf7.zip
Adopt package, fix buffer overflow (kinda), bug 442290, and impossible game speed. Drop to ~arch as we're returning from package mask.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key B6C5F7DE)
Diffstat (limited to 'games-arcade/xboing')
-rw-r--r--games-arcade/xboing/ChangeLog10
-rw-r--r--games-arcade/xboing/files/xboing-2.4-buffer.patch12
-rw-r--r--games-arcade/xboing/files/xboing-2.4-sleep.patch13
-rw-r--r--games-arcade/xboing/metadata.xml2
-rw-r--r--games-arcade/xboing/xboing-2.4-r2.ebuild (renamed from games-arcade/xboing/xboing-2.4-r1.ebuild)17
5 files changed, 44 insertions, 10 deletions
diff --git a/games-arcade/xboing/ChangeLog b/games-arcade/xboing/ChangeLog
index dde31cfbd2c4..31285575d1f6 100644
--- a/games-arcade/xboing/ChangeLog
+++ b/games-arcade/xboing/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/xboing
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/ChangeLog,v 1.14 2011/01/08 20:58:52 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/ChangeLog,v 1.15 2013/02/02 19:19:26 dilfridge Exp $
+
+ 02 Feb 2013; Andreas K. Huettel <dilfridge@gentoo.org> -xboing-2.4-r1.ebuild,
+ +xboing-2.4-r2.ebuild, +files/xboing-2.4-buffer.patch,
+ +files/xboing-2.4-sleep.patch, metadata.xml:
+ Adopt package, fix buffer overflow (kinda), bug 442290, and impossible game
+ speed. Drop to ~arch as we're returning from package mask.
08 Jan 2011; Tupone Alfredo <tupone@gentoo.org> xboing-2.4-r1.ebuild:
Again respect LDFLAGS. Bug #351038 by flameeyes@gentoo.org
diff --git a/games-arcade/xboing/files/xboing-2.4-buffer.patch b/games-arcade/xboing/files/xboing-2.4-buffer.patch
new file mode 100644
index 000000000000..381ae69982d9
--- /dev/null
+++ b/games-arcade/xboing/files/xboing-2.4-buffer.patch
@@ -0,0 +1,12 @@
+diff -ruN xboing.orig/init.c xboing/init.c
+--- xboing.orig/init.c 1996-11-22 02:28:46.000000000 +0100
++++ xboing/init.c 2013-02-02 19:57:55.000000000 +0100
+@@ -266,7 +266,7 @@
+ #endif
+ {
+ /* Create all required font structures */
+- char str[80];
++ char str[200];
+
+ /* Font used for titles */
+ if (!(titleFont = XLoadQueryFont(display, TITLE_FONT)))
diff --git a/games-arcade/xboing/files/xboing-2.4-sleep.patch b/games-arcade/xboing/files/xboing-2.4-sleep.patch
new file mode 100644
index 000000000000..80723465185f
--- /dev/null
+++ b/games-arcade/xboing/files/xboing-2.4-sleep.patch
@@ -0,0 +1,13 @@
+diff -ru xboing.debian/misc.c xboing/misc.c
+--- xboing.debian/misc.c 2013-02-02 20:07:07.000000000 +0100
++++ xboing/misc.c 2013-02-02 20:11:51.000000000 +0100
+@@ -116,9 +116,7 @@
+ long SyncTime;
+ static unsigned long accu;
+
+-#ifdef __alpha__
+ ms *= 1000; /* convert from milliseconds to microseconds for usleep */
+-#endif
+
+ gettimeofday(&st, NULL);
+ XSync(display, False);
diff --git a/games-arcade/xboing/metadata.xml b/games-arcade/xboing/metadata.xml
index d3c2cc926f0b..57c4c091b3ea 100644
--- a/games-arcade/xboing/metadata.xml
+++ b/games-arcade/xboing/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>games</herd>
+<maintainer><email>dilfridge@gentoo.org</email></maintainer>
</pkgmetadata>
diff --git a/games-arcade/xboing/xboing-2.4-r1.ebuild b/games-arcade/xboing/xboing-2.4-r2.ebuild
index db7afa0ced70..1947e0070381 100644
--- a/games-arcade/xboing/xboing-2.4-r1.ebuild
+++ b/games-arcade/xboing/xboing-2.4-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/xboing-2.4-r1.ebuild,v 1.13 2011/01/08 20:58:52 tupone Exp $
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/xboing-2.4-r2.ebuild,v 1.3 2013/02/02 19:19:26 dilfridge Exp $
+
+EAPI=5
inherit eutils games
@@ -12,7 +13,7 @@ SRC_URI="http://www.techrescue.org/xboing/${PN}${PV}.tar.gz
LICENSE="xboing"
SLOT="0"
-KEYWORDS="ppc sparc x86"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="x11-libs/libXpm"
@@ -25,6 +26,8 @@ S=${WORKDIR}/${PN}
src_prepare() {
epatch "${WORKDIR}"/xboing-${PV}-debian.patch
+ epatch "${FILESDIR}"/xboing-${PV}-buffer.patch
+ epatch "${FILESDIR}"/xboing-${PV}-sleep.patch
sed -i '/^#include/s:xpm\.h:X11/xpm.h:' *.c
}
@@ -40,15 +43,15 @@ src_compile() {
CXXOPTIONS="${CXXFLAGS}" \
CDEBUGFLAGS="${CFLAGS}" \
LOCAL_LDFLAGS="${LDFLAGS}" \
- XBOING_DIR=${GAMES_DATADIR}/${PN} \
+ XBOING_DIR="${GAMES_DATADIR}/${PN}" \
|| die
}
src_install() {
make \
- PREFIX=${D} \
+ PREFIX="${D}" \
LOCAL_LDFLAGS="${LDFLAGS}" \
- XBOING_DIR=${GAMES_DATADIR}/${PN} \
+ XBOING_DIR="${GAMES_DATADIR}/${PN}" \
install \
|| die
newman xboing.man xboing.6