summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-10 21:55:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-10 21:55:08 +0000
commita165cacaff66f9764ab8ff073b7ac0517a6714df (patch)
treefd0d44d473ff255d6f40fdc4e34d3f954cf0c46c /games-arcade/stepmania
parentUpdated 2.4 to latest tomcat sources, package needs to be renamed and version... (diff)
downloadgentoo-2-a165cacaff66f9764ab8ff073b7ac0517a6714df.tar.gz
gentoo-2-a165cacaff66f9764ab8ff073b7ac0517a6714df.tar.bz2
gentoo-2-a165cacaff66f9764ab8ff073b7ac0517a6714df.zip
Fix typo and cleanup, bug #157601
(Portage version: 2.1.2_rc3-r1)
Diffstat (limited to 'games-arcade/stepmania')
-rw-r--r--games-arcade/stepmania/ChangeLog5
-rw-r--r--games-arcade/stepmania/stepmania-3.9.ebuild58
2 files changed, 36 insertions, 27 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index ca7b105a74f6..bd0991afe86a 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/stepmania
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.14 2006/12/01 22:19:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.15 2006/12/10 21:55:08 nyhm Exp $
+
+ 10 Dec 2006; Tristan Heaven <nyhm@gentoo.org> stepmania-3.9.ebuild:
+ Fix typo and cleanup, bug #157601
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> stepmania-3.9.ebuild:
Added built_with_use check for bug #156609.
diff --git a/games-arcade/stepmania/stepmania-3.9.ebuild b/games-arcade/stepmania/stepmania-3.9.ebuild
index c1c330a0e0b4..c60bed52fb4f 100644
--- a/games-arcade/stepmania/stepmania-3.9.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.6 2006/12/01 22:19:28 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.7 2006/12/10 21:55:08 nyhm Exp $
+WANT_AUTOCONF=latest
inherit eutils autotools games
-IUSE="debug gtk jpeg mp3 mpeg vorbis force-oss"
-
MY_PV="${PV/_/-}"
-S="${WORKDIR}/StepMania-${MY_PV}-src"
-SMDATA="${WORKDIR}/StepMania-${MY_PV}"
DESCRIPTION="An advanced DDR simulator"
HOMEPAGE="http://www.stepmania.com/stepmania/"
SRC_URI="mirror://sourceforge/stepmania/StepMania-${MY_PV}-src.tar.gz
mirror://sourceforge/stepmania/StepMania-${MY_PV}-linux.tar.gz"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug gtk jpeg mp3 mpeg vorbis force-oss"
+RESTRICT="test"
DEPEND="gtk? ( >=x11-libs/gtk+-2.0 )
mp3? ( media-libs/libmad )
@@ -24,20 +23,27 @@ DEPEND="gtk? ( >=x11-libs/gtk+-2.0 )
media-libs/libsdl
jpeg? ( media-libs/jpeg )
media-libs/libpng
- sys-libs/zlib
mpeg? ( media-video/ffmpeg )
vorbis? ( media-libs/libvorbis )
- virtual/opengl"
+ virtual/opengl
+ virtual/glu"
+
+S=${WORKDIR}/StepMania-${MY_PV}-src
pkg_setup() {
- built_with_use media-libs/libsdl opengl || \
- die "You need to compile meida-libs/libsdl with USE=opengl."
+ games_pkg_setup
+ built_with_use media-libs/libsdl opengl \
+ || die "You need to compile media-libs/libsdl with USE=opengl."
}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}"-gentoo.patch \
+ sed "s:/usr/share/games/${PN}:${GAMES_DATADIR}/${PN}:" \
+ "${FILESDIR}"/${P}-gentoo.patch > "${T}"/gentoo.patch \
+ || die "sed failed"
+ epatch \
+ "${T}"/gentoo.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-64bits.patch \
"${FILESDIR}/${P}"-ffmpeg.patch \
@@ -49,38 +55,38 @@ src_unpack() {
src_compile() {
econf \
+ --disable-dependency-tracking \
$(use_with debug) \
$(use_with jpeg) \
$(use_with vorbis) \
$(use_with mp3) \
$(use_enable gtk gtk2) \
$(use_enable force-oss) \
- || die "Configure failed"
-
- emake || die "Make failed"
+ || die
+ emake || die "emake failed"
}
src_install() {
local dir=${GAMES_DATADIR}/${PN}
- dodir ${dir}
- exeinto ${dir}
- doexe src/stepmania || die "Install failed"
+ exeinto "${dir}"
+ doexe src/stepmania || die "doexe failed"
if use gtk; then
- doexe src/GtkModule.so || die "Install failed"
+ doexe src/GtkModule.so || die "doexe failed"
fi
- insinto ${dir}
+ cd "${WORKDIR}"/StepMania-${MY_PV}
+
+ insinto "${dir}"
+ doins -r Announcers BGAnimations CDTitles Characters Courses Data Docs \
+ NoteSkins RandomMovies Songs Themes Visualizations || die "doins failed"
- cd ${SMDATA}
- doins Copying.txt NEWS README-FIRST.html || die "Install failed"
- cp -r Announcers BGAnimations CDTitles Characters Courses Data Docs \
- NoteSkins RandomMovies Songs Themes Visualizations ${D}/${dir} || die "Install failed"
+ dodoc Copying.txt NEWS README-FIRST.html
- make_desktop_entry stepmania Stepmania stepmania.png
- newicon Themes/default/Graphics/Common\ window\ icon.png stepmania.png
+ make_desktop_entry ${PN} Stepmania
+ newicon "Themes/default/Graphics/Common window icon.png" ${PN}.png
- games_make_wrapper stepmania ${dir}/stepmania ${dir}
+ games_make_wrapper ${PN} "${dir}"/${PN} "${dir}"
prepgamesdirs
}