summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-25 18:57:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-25 18:57:51 +0000
commitaedbd155c5f12bcbdc38ee68f577b20ef167e3d6 (patch)
tree6645027fa276302529fa3116ace2bba34eee8e2e /games-arcade/holotz-castle
parentStable on ppc wrt bug 228967 (diff)
downloadgentoo-2-aedbd155c5f12bcbdc38ee68f577b20ef167e3d6.tar.gz
gentoo-2-aedbd155c5f12bcbdc38ee68f577b20ef167e3d6.tar.bz2
gentoo-2-aedbd155c5f12bcbdc38ee68f577b20ef167e3d6.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade/holotz-castle')
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch53
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild42
2 files changed, 0 insertions, 95 deletions
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
deleted file mode 100644
index e556d76193e9..000000000000
--- a/games-arcade/holotz-castle/files/holotz-castle-1.3.8-build.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- JLib/Makefile.orig 2006-03-26 23:38:39.000000000 -0500
-+++ JLib/Makefile 2006-03-27 01:16:36.000000000 -0500
-@@ -19,7 +19,7 @@
- endif
-
- # Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
--CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
-+CXXFLAGS=-I. $(CPU_OPTS) `$(SDL_CONFIG) --cflags`
-
- # Sample LDFLAGS for applications
- # LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-@@ -28,15 +28,14 @@
-
- # JLib
- libJLib: $(JLIB_OBJS)
-- g++ -shared -fPIC -o $@.so $? \
-- && ar rvus $@.a $? \
-+ ar rvus $@.a $?
-
- $(GRAPHICS)/%.o: $(GRAPHICS)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
- $(UTIL)/%.o: $(UTIL)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
- $(MATH)/%.o: $(MATH)/%.cpp
-- g++ $(CFLAGS) -c -o $@ $<
-+ $(CXX) $(CXXFLAGS) -c -o $@ $<
-
- .PHONY: install
- install:
---- src/Makefile.orig 2006-03-27 01:26:18.000000000 -0500
-+++ src/Makefile 2006-03-27 01:27:31.000000000 -0500
-@@ -30,7 +30,7 @@
-
- DEFINES = -DHC_DATA_DIR=\"$(HC_DATA)\" -DHCED_DATA_DIR=\"$(HCED_DATA)\"
-
--all: JLib HC HCed
-+all: HC HCed
-
- HC_OBJ_MAIN=HolotzCastle.o
- HC_OBJS=HCUtil.o HCTimer.o HCLoadSaveSlot.o HCPlaylist.o HCPreferences.o HCTheme.o HCText.o \
-@@ -42,8 +42,8 @@
-
- # Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
- # Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
--CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
--LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-+CFLAGS=-I. -I../JLib $(CPU_OPTS) -c `$(SDL_CONFIG) --cflags`
-+LDFLAGS=-L. -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
-
-
- JLib:
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
deleted file mode 100644
index ebf22f805421..000000000000
--- a/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.8.ebuild,v 1.3 2006/10/03 15:17:46 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="2d platform jump'n'run game"
-HOMEPAGE="http://www.mainreactor.net/holotzcastle/en/index_en.html"
-SRC_URI="http://www.mainreactor.net/holotzcastle/download/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="virtual/opengl
- media-libs/sdl-mixer
- media-libs/libsdl
- media-libs/sdl-ttf
- media-libs/sdl-image"
-
-S=${WORKDIR}/${P}-src
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-build.patch
-}
-
-src_compile() {
- emake -C JLib CPU_OPTS="${CXXFLAGS}" || die "emake failed"
- emake -C src CPU_OPTS="${CXXFLAGS}" || die "emake failed"
-}
-
-src_install() {
- dogamesbin holotz-castle holotz-castle-editor || die "dogamesbin failed"
- insinto "${GAMES_DATADIR}"/${PN}/game
- doins -r HCedHome/* res/* || die "doins failed"
- dodoc MANUAL*.txt
- doman doc/*.6
- prepgamesdirs
-}