summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-04-26 16:22:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-04-26 16:22:32 +0000
commitc76b1c75e375d0d161fbf4f9b23cc1dc621e0c75 (patch)
tree25362884bd1c502f6704822110db00b1f0a6cd3a /games-action
parentStable on ppc wrt bug 209059 (diff)
downloadgentoo-2-c76b1c75e375d0d161fbf4f9b23cc1dc621e0c75.tar.gz
gentoo-2-c76b1c75e375d0d161fbf4f9b23cc1dc621e0c75.tar.bz2
gentoo-2-c76b1c75e375d0d161fbf4f9b23cc1dc621e0c75.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/blobandconquer/ChangeLog10
-rw-r--r--games-action/blobandconquer/blobandconquer-0.92.ebuild51
2 files changed, 59 insertions, 2 deletions
diff --git a/games-action/blobandconquer/ChangeLog b/games-action/blobandconquer/ChangeLog
index e332a6f8333d..0a2f903285c8 100644
--- a/games-action/blobandconquer/ChangeLog
+++ b/games-action/blobandconquer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/blobandconquer
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.4 2007/05/28 21:46:31 nyhm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/ChangeLog,v 1.5 2008/04/26 16:22:32 mr_bones_ Exp $
+
+*blobandconquer-0.92 (26 Apr 2008)
+
+ 26 Apr 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +blobandconquer-0.92.ebuild:
+ version bump
*blobandconquer-0.91 (28 May 2007)
diff --git a/games-action/blobandconquer/blobandconquer-0.92.ebuild b/games-action/blobandconquer/blobandconquer-0.92.ebuild
new file mode 100644
index 000000000000..68e4b60c496f
--- /dev/null
+++ b/games-action/blobandconquer/blobandconquer-0.92.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/blobandconquer/blobandconquer-0.92.ebuild,v 1.1 2008/04/26 16:22:32 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs games
+
+MY_PN=blobAndConquer
+DESCRIPTION="Mission and objective based 3D action game"
+HOMEPAGE="http://www.parallelrealities.co.uk/blobAndConquer.php"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-ttf"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_compile() {
+ emake \
+ CXX=$(tc-getCXX) \
+ LIBPATH="${LDFLAGS}" \
+ DATADIR="${GAMES_DATADIR}"/${PN}/ \
+ DOCDIR=/usr/share/doc/${PF}/html/ \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${MY_PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data gfx music sound textures || die "doins failed"
+ doicon icons/${MY_PN}.png
+ domenu icons/${MY_PN}.desktop
+ cd doc
+ dohtml -r images pages index.html
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "Until ${PN}-1.0, save games may be incompatible with previous"
+ ewarn "versions."
+}