summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-12-14 10:57:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-12-14 10:57:31 +0000
commit6dd540510f85543fec9cdfb80f10a3461d609e38 (patch)
treedc00fa04a0b430f3fc260fd64ebcefe9fb17a652 /games-action
parentFix quoting n00bness (diff)
downloadgentoo-2-6dd540510f85543fec9cdfb80f10a3461d609e38.tar.gz
gentoo-2-6dd540510f85543fec9cdfb80f10a3461d609e38.tar.bz2
gentoo-2-6dd540510f85543fec9cdfb80f10a3461d609e38.zip
version bump
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/wordwarvi/ChangeLog8
-rw-r--r--games-action/wordwarvi/wordwarvi-0.24.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
index c51e919792c0..a22d4210602a 100644
--- a/games-action/wordwarvi/ChangeLog
+++ b/games-action/wordwarvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/wordwarvi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.2 2008/12/02 21:46:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.3 2008/12/14 10:57:31 mr_bones_ Exp $
+
+*wordwarvi-0.24 (14 Dec 2008)
+
+ 14 Dec 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +wordwarvi-0.24.ebuild:
+ version bump
*wordwarvi-0.23 (02 Dec 2008)
diff --git a/games-action/wordwarvi/wordwarvi-0.24.ebuild b/games-action/wordwarvi/wordwarvi-0.24.ebuild
new file mode 100644
index 000000000000..d87dbddf3229
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-0.24.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-0.24.ebuild,v 1.1 2008/12/14 10:57:31 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis"
+
+RDEPEND="x11-libs/gtk+:2
+ vorbis? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^DATADIR/s/=/?=/' \
+ -e '/^OPTIMIZE_FLAG/s/=.*/=$(CFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ install || die "emake install failed"
+ use vorbis || rm -rf "${D}${GAMES_DATADIR}/${PN}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}