summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 19:25:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 19:25:50 +0000
commitab684af50a9c0d9b908e19d26e1e2ed22bf3aead (patch)
tree97a11d1bb5621eea4482387dfc720412f0992545 /games-action/violetland
parentold (diff)
downloadgentoo-2-ab684af50a9c0d9b908e19d26e1e2ed22bf3aead.tar.gz
gentoo-2-ab684af50a9c0d9b908e19d26e1e2ed22bf3aead.tar.bz2
gentoo-2-ab684af50a9c0d9b908e19d26e1e2ed22bf3aead.zip
initial commit - ebuild submitted by Azamat H. Hackimov via bug #294776
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action/violetland')
-rw-r--r--games-action/violetland/ChangeLog10
-rw-r--r--games-action/violetland/metadata.xml5
-rw-r--r--games-action/violetland/violetland-0.2.4.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
new file mode 100644
index 000000000000..ad996f776ee0
--- /dev/null
+++ b/games-action/violetland/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/violetland
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.1 2009/11/30 19:25:50 mr_bones_ Exp $
+
+*violetland-0.2.4 (30 Nov 2009)
+
+ 30 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.2.4.ebuild, +metadata.xml:
+ initial commit - ebuild submitted by Azamat H. Hackimov via bug #294776
+
diff --git a/games-action/violetland/metadata.xml b/games-action/violetland/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/violetland/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/violetland/violetland-0.2.4.ebuild b/games-action/violetland/violetland-0.2.4.ebuild
new file mode 100644
index 000000000000..120d1f5a81dc
--- /dev/null
+++ b/games-action/violetland/violetland-0.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.2.4.ebuild,v 1.1 2009/11/30 19:25:50 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libX11
+ x11-libs/libXext
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs="\
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX} \
+ -DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ DOCS="README_EN.TXT" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}