summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-08 14:33:20 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-08 14:33:20 +0000
commitf5427de5d0aeb89663ddc69a1aa1b48e2847607d (patch)
treeb5269aa3a02db5872496efb0a4421fec05abb6f3 /dev-vcs
parentia64 stable wrt bug #500298 (diff)
downloadgentoo-2-f5427de5d0aeb89663ddc69a1aa1b48e2847607d.tar.gz
gentoo-2-f5427de5d0aeb89663ddc69a1aa1b48e2847607d.tar.bz2
gentoo-2-f5427de5d0aeb89663ddc69a1aa1b48e2847607d.zip
dev-vcs/gitg: Version Bump, #497358; thanks for Mark R. Pariente, Konstantin and Jesús Pérez (Chuso) working on the ebuild
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/gitg/ChangeLog11
-rw-r--r--dev-vcs/gitg/gitg-0.3.2.ebuild77
-rw-r--r--dev-vcs/gitg/metadata.xml25
3 files changed, 99 insertions, 14 deletions
diff --git a/dev-vcs/gitg/ChangeLog b/dev-vcs/gitg/ChangeLog
index fb461c92d2f8..abaeb4209858 100644
--- a/dev-vcs/gitg/ChangeLog
+++ b/dev-vcs/gitg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/gitg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.24 2013/08/18 13:26:33 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/ChangeLog,v 1.25 2014/02/08 14:33:20 jlec Exp $
+
+*gitg-0.3.2 (08 Feb 2014)
+
+ 08 Feb 2014; Justin Lecher <jlec@gentoo.org> +gitg-0.3.2.ebuild,
+ metadata.xml:
+ Version Bump, #497358; thanks for Mark R. Pariente, Konstantin and Jesús
+ Pérez (Chuso) working on the ebuild
18 Aug 2013; Agostino Sarubbo <ago@gentoo.org> gitg-0.2.7.ebuild:
Stable for x86, wrt bug #478274
diff --git a/dev-vcs/gitg/gitg-0.3.2.ebuild b/dev-vcs/gitg/gitg-0.3.2.ebuild
new file mode 100644
index 000000000000..b7a3c30e67a4
--- /dev/null
+++ b/dev-vcs/gitg/gitg-0.3.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/gitg/gitg-0.3.2.ebuild,v 1.1 2014/02/08 14:33:20 jlec Exp $
+
+EAPI=5
+
+VALA_MIN_API_VERSION="0.20"
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit autotools gnome2 python-r1 vala
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug glade +python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# test if unbundling of libgd is possible
+# Currently it seems not to be (unstable API/ABI)
+RDEPEND="
+ dev-libs/libgee:0.8
+ >=dev-libs/json-glib-0.16
+ >=app-text/gtkspell-3.0.3:3
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.10.1
+ dev-libs/libgit2[threads]
+ >=dev-libs/libgit2-glib-0.0.10
+ >=dev-libs/libpeas-1.5.0[gtk]
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ >=net-libs/webkit-gtk-2.2:3[introspection]
+ >=x11-libs/gtk+-3.10.0:3
+ >=x11-libs/gtksourceview-3.10:3.0
+ glade? ( >=dev-util/glade-3.2:3.10 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/libpeas[python,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40
+ $(vala_depend)"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed \
+ -e '/CFLAGS/s:-g::g' \
+ -e '/CFLAGS/s:-O0::g' \
+ -i configure.ac || die
+ eautoreconf
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ # Disable maintainer to get rid of -Werror (bug #363009)
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-deprecations
+ --disable-dependency-tracking
+ $(use_enable debug)
+ $(use_enable glade glade-catalog)
+ $(use_enable python)"
+
+ gnome2_src_configure
+}
+
+src_install() {
+ gnome2_src_install -j1
+}
diff --git a/dev-vcs/gitg/metadata.xml b/dev-vcs/gitg/metadata.xml
index cd4ae38b3acf..34139830e920 100644
--- a/dev-vcs/gitg/metadata.xml
+++ b/dev-vcs/gitg/metadata.xml
@@ -1,18 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>ikelos@gentoo.org</email>
- <name>Mike Auty</name>
- </maintainer>
- <maintainer>
- <email>sping@gentoo.org</email>
- <name>Sebastian Pipping</name>
- </maintainer>
- <longdescription lang="en">
+ <maintainer>
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ </maintainer>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <longdescription lang="en">
GTK+ based frontend for GIT
</longdescription>
- <use>
- <flag name="glade">Install a glade catalog file</flag>
- </use>
+ <use>
+ <flag name="glade">Install a glade catalog file</flag>
+ <flag name="python">Install Python bindings for those plugins requiring it.</flag>
+ </use>
</pkgmetadata>