summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-08-11 17:59:13 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-08-11 17:59:13 +0000
commitea54c0195a29192c35932490e6bc372117abfffb (patch)
tree5521280ec0d01d503e235ae1b2edaa8ba53dbd8a /dev-vcs/topgit
parentNew snapshot of trunk. (diff)
downloadgentoo-2-ea54c0195a29192c35932490e6bc372117abfffb.tar.gz
gentoo-2-ea54c0195a29192c35932490e6bc372117abfffb.tar.bz2
gentoo-2-ea54c0195a29192c35932490e6bc372117abfffb.zip
Version bump, bug 518956
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'dev-vcs/topgit')
-rw-r--r--dev-vcs/topgit/ChangeLog9
-rw-r--r--dev-vcs/topgit/topgit-0.9.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-vcs/topgit/ChangeLog b/dev-vcs/topgit/ChangeLog
index a1ba71449840..b77d5ee2e10f 100644
--- a/dev-vcs/topgit/ChangeLog
+++ b/dev-vcs/topgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/topgit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/topgit/ChangeLog,v 1.4 2013/03/02 22:47:47 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/topgit/ChangeLog,v 1.5 2014/08/11 17:59:13 idl0r Exp $
+
+*topgit-0.9 (11 Aug 2014)
+
+ 11 Aug 2014; Christian Ruppert <idl0r@gentoo.org> +topgit-0.9.ebuild:
+ Version bump, bug 518956
02 Mar 2013; Christoph Junghans <ottxor@gentoo.org> topgit-0.8.ebuild:
switched to virtual/awk (bug #455728)
diff --git a/dev-vcs/topgit/topgit-0.9.ebuild b/dev-vcs/topgit/topgit-0.9.ebuild
new file mode 100644
index 000000000000..ec38df47a774
--- /dev/null
+++ b/dev-vcs/topgit/topgit-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/topgit/topgit-0.9.ebuild,v 1.1 2014/08/11 17:59:13 idl0r Exp $
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="A different patch queue manager"
+HOMEPAGE="https://github.com/greenrd/topgit"
+SRC_URI="https://github.com/greenrd/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+DEPEND="sys-apps/sed
+ virtual/awk"
+RDEPEND="dev-vcs/git"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_compile() {
+ # Needed because of "hardcoded" paths
+ emake prefix="/usr" sharedir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake prefix="${D}/usr" sharedir="${D}/usr/share/doc/${PF}" install
+
+ if use bash-completion; then
+ newbashcomp contrib/tg-completion.bash ${PN}
+ fi
+
+ dodoc README
+}