summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-06-19 00:30:49 +0000
committerJonathan Callen <abcd@gentoo.org>2010-06-19 00:30:49 +0000
commitac6a73ab86e516f8b52f7aa918b4865d9ff50f55 (patch)
treef4579ba3ba9135d443acf72f085f0641cf43e9ea /dev-vcs/cvsd/cvsd-1.0.8.ebuild
parentMove package from dev-util/cvs2cl to dev-vcs/cvs2cl (diff)
downloadgentoo-2-ac6a73ab86e516f8b52f7aa918b4865d9ff50f55.tar.gz
gentoo-2-ac6a73ab86e516f8b52f7aa918b4865d9ff50f55.tar.bz2
gentoo-2-ac6a73ab86e516f8b52f7aa918b4865d9ff50f55.zip
Move package from dev-util/cvsd to dev-vcs/cvsd
(Portage version: 2.2_rc67/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'dev-vcs/cvsd/cvsd-1.0.8.ebuild')
-rw-r--r--dev-vcs/cvsd/cvsd-1.0.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-vcs/cvsd/cvsd-1.0.8.ebuild b/dev-vcs/cvsd/cvsd-1.0.8.ebuild
new file mode 100644
index 000000000000..c3b8a4ab31f8
--- /dev/null
+++ b/dev-vcs/cvsd/cvsd-1.0.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvsd/cvsd-1.0.8.ebuild,v 1.1 2010/06/19 00:30:49 abcd Exp $
+
+inherit eutils
+
+DESCRIPTION="CVS pserver daemon."
+HOMEPAGE="http://ch.tudelft.nl/~arthur/cvsd/"
+SRC_URI="http://ch.tudelft.nl/~arthur/cvsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+RDEPEND="${DEPEND}
+ >=dev-lang/perl-5.8.0
+ >=dev-vcs/cvs-1.11.6"
+
+pkg_setup() {
+ enewgroup cvsd
+ enewuser cvsd -1 -1 /var/lib/cvsd cvsd
+}
+
+src_compile() {
+ econf $(use_with tcpd libwrap) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dosed 's:^Repos:# Repos:g' /etc/cvsd/cvsd.conf
+ keepdir /var/lib/cvsd
+
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
+
+ newinitd "${FILESDIR}"/cvsd.rc6 ${PN}
+}
+
+pkg_postinst() {
+ elog "To configure cvsd please read the README in "
+ elog "/usr/share/doc/${PF}/"
+}