summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2008-05-08 15:53:11 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2008-05-08 15:53:11 +0000
commitc51aa15836fde3b56829fd98494b32bdd1bf10ce (patch)
tree752651128aed7429569c84c9c4d3413f296a29b8 /dev-util
parentMasking dev-util/cmake-2.6.0 until it has received a little more (diff)
downloadgentoo-2-c51aa15836fde3b56829fd98494b32bdd1bf10ce.tar.gz
gentoo-2-c51aa15836fde3b56829fd98494b32bdd1bf10ce.tar.bz2
gentoo-2-c51aa15836fde3b56829fd98494b32bdd1bf10ce.zip
Version bump, masked for now until it receives wider testing.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog8
-rw-r--r--dev-util/cmake/cmake-2.6.0.ebuild99
-rw-r--r--dev-util/cmake/files/cmake-FindPythonLibs.patch13
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 8369d7b7bede..9d41ed393ec1 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.71 2008/02/22 18:00:15 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.72 2008/05/08 15:53:11 cryos Exp $
+
+*cmake-2.6.0 (08 May 2008)
+
+ 08 May 2008; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/cmake-FindPythonLibs.patch, +cmake-2.6.0.ebuild:
+ Version bump, masked for now until it receives wider testing.
22 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -cmake-2.0.6-r1.ebuild,
-cmake-2.4.3.ebuild, -cmake-2.4.4.ebuild, -cmake-2.4.5.ebuild,
diff --git a/dev-util/cmake/cmake-2.6.0.ebuild b/dev-util/cmake/cmake-2.6.0.ebuild
new file mode 100644
index 000000000000..657d2c2d2258
--- /dev/null
+++ b/dev-util/cmake/cmake-2.6.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.0.ebuild,v 1.1 2008/05/08 15:53:11 cryos Exp $
+
+inherit elisp-common toolchain-funcs eutils versionator qt3 flag-o-matic
+
+MY_PV="${PV/rc/RC-}"
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs vim-syntax"
+
+DEPEND=">=net-misc/curl-7.16.4
+ >=dev-libs/expat-2.0.1
+ >=dev-libs/libxml2-2.6.28
+ >=dev-libs/xmlrpc-c-1.06.09
+ emacs? ( virtual/emacs )
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+pkg_setup() {
+ if ! built_with_use -o dev-libs/xmlrpc-c curl libwww; then
+ echo
+ eerror "${PN} requires dev-libs/xmlrpc-c to be built with either the 'libwww' or"
+ eerror "the 'curl' USE flag or both enabled."
+ eerror "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
+ echo
+ die "Please re-emerge dev-libs/xmlrpc-c with USE=\"libwww\" or USE=\"curl\"."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Link against the shared Python library rather than the static one
+ epatch "${FILESDIR}/${PN}-FindPythonLibs.patch"
+}
+
+src_compile() {
+ if [[ "$(gcc-major-version)" -eq "3" ]] ; then
+ append-flags "-fno-stack-protector"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --system-libs \
+ --prefix=/usr \
+ --docdir=/share/doc/${PF} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man || die "./bootstrap failed"
+ emake || die "emake failed."
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ emake test || \
+ einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins "${S}"/Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-FindPythonLibs.patch b/dev-util/cmake/files/cmake-FindPythonLibs.patch
new file mode 100644
index 000000000000..f473cffd9d18
--- /dev/null
+++ b/dev-util/cmake/files/cmake-FindPythonLibs.patch
@@ -0,0 +1,13 @@
+--- Modules/FindPythonLibs.cmake 2008-05-08 11:18:22.000000000 -0400
++++ Modules/FindPythonLibs.cmake 2008-05-08 11:18:40.000000000 -0400
+@@ -27,10 +27,6 @@
+ NAMES python${_CURRENT_VERSION_NO_DOTS} python${_CURRENT_VERSION}
+ PATHS
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\${_CURRENT_VERSION}\\InstallPath]/libs
+- PATH_SUFFIXES
+- python${_CURRENT_VERSION}/config
+- # Avoid finding the .dll in the PATH. We want the .lib.
+- NO_SYSTEM_ENVIRONMENT_PATH
+ )
+
+ SET(PYTHON_FRAMEWORK_INCLUDES)