summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-02-05 21:01:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-02-05 21:01:40 +0000
commita87c1364731fc2927a2ccb5ebd57ddbaf74f7d49 (patch)
tree58b731f34c66b9afaf9c9ddbf6bf9edcb7a4e265 /dev-util
parentAutomated update. (diff)
downloadgentoo-2-a87c1364731fc2927a2ccb5ebd57ddbaf74f7d49.tar.gz
gentoo-2-a87c1364731fc2927a2ccb5ebd57ddbaf74f7d49.tar.bz2
gentoo-2-a87c1364731fc2927a2ccb5ebd57ddbaf74f7d49.zip
Version bump (bug #500312 by Dirkjan Ochtman).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/include-what-you-use/ChangeLog10
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-3.4.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/include-what-you-use/ChangeLog b/dev-util/include-what-you-use/ChangeLog
index 468eb6d384eb..48280b13ee78 100644
--- a/dev-util/include-what-you-use/ChangeLog
+++ b/dev-util/include-what-you-use/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/include-what-you-use
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/ChangeLog,v 1.2 2013/10/03 06:17:19 slyfox Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/ChangeLog,v 1.3 2014/02/05 21:01:40 slyfox Exp $
+
+*include-what-you-use-3.4 (05 Feb 2014)
+
+ 05 Feb 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +include-what-you-use-3.4.ebuild:
+ Version bump (bug #500312 by Dirkjan Ochtman).
03 Oct 2013; Sergei Trofimovich <slyfox@gentoo.org>
include-what-you-use-3.3-r1.ebuild:
diff --git a/dev-util/include-what-you-use/include-what-you-use-3.4.ebuild b/dev-util/include-what-you-use/include-what-you-use-3.4.ebuild
new file mode 100644
index 000000000000..9222ba865fde
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/include-what-you-use-3.4.ebuild,v 1.1 2014/02/05 21:01:40 slyfox Exp $
+
+EAPI=5
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="find unused include directives in C/C++ programs"
+HOMEPAGE="https://code.google.com/p/include-what-you-use/"
+# picked from google drive
+SRC_URI="http://dev.gentoo.org/~slyfox/distfiles/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sys-devel/llvm-3.4*
+ =sys-devel/clang-3.4*"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ append-ldflags -L$(llvm-config --libdir)
+
+ local mycmakeargs=(
+ -DLLVM_PATH=$(llvm-config --libdir)
+ )
+ cmake-utils_src_configure
+}