summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-01 19:47:05 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-01 19:47:05 +0000
commit635bf2a11f2ab6f5b27ce24f3f2e17728b85fb58 (patch)
tree2bd71ac4a29d32603961aa33ee6b3873d66f1928 /dev-util
parentAdd patch to build on FreeBSD, and mark ~x86-fbsd. Bug #131897. (diff)
downloadgentoo-2-635bf2a11f2ab6f5b27ce24f3f2e17728b85fb58.tar.gz
gentoo-2-635bf2a11f2ab6f5b27ce24f3f2e17728b85fb58.tar.bz2
gentoo-2-635bf2a11f2ab6f5b27ce24f3f2e17728b85fb58.zip
Version bump to fix a few bugs. Closing bug #131181, bug #131190, and bug #131502.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/ChangeLog9
-rw-r--r--dev-util/catalyst/catalyst-2.0_rc45.ebuild96
-rw-r--r--dev-util/catalyst/files/catalyst-2.0_rc45-slot.patch30
-rw-r--r--dev-util/catalyst/files/digest-catalyst-2.0_rc453
4 files changed, 137 insertions, 1 deletions
diff --git a/dev-util/catalyst/ChangeLog b/dev-util/catalyst/ChangeLog
index c445f791a812..8df90bcd138c 100644
--- a/dev-util/catalyst/ChangeLog
+++ b/dev-util/catalyst/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/catalyst
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.146 2006/04/20 15:24:06 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.147 2006/05/01 19:47:05 wolf31o2 Exp $
+
+*catalyst-2.0_rc45 (01 May 2006)
+
+ 01 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/catalyst-2.0_rc45-slot.patch, +catalyst-2.0_rc45.ebuild:
+ Version bump to fix a few bugs. Closing bug #131181, bug #131190, and bug
+ #131502.
*catalyst-2.0_rc44 (20 Apr 2006)
diff --git a/dev-util/catalyst/catalyst-2.0_rc45.ebuild b/dev-util/catalyst/catalyst-2.0_rc45.ebuild
new file mode 100644
index 000000000000..ff0cc951348d
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0_rc45.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc45.ebuild,v 1.1 2006/05/01 19:47:05 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+ app-crypt/shash
+ amd64? ( sys-apps/setarch )
+ ppc64? ( sys-apps/setarch )
+ ccache? ( dev-util/ccache )
+ cdr? (
+ virtual/cdrtools
+ ia64? ( sys-fs/dosfstools )
+ app-misc/zisofs-tools
+ >=sys-fs/squashfs-tools-2.1
+ )
+ examples? (
+ dev-util/livecd-kconfigs
+ dev-util/livecd-specs )"
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-slot.patch
+}
+
+src_install() {
+ ewarn "This version of the ebuild is slotted to allow side-by-side"
+ ewarn "installation with catalyst 1.x for use on build servers. The final"
+ ewarn "version of this ebuild will not be slotted, as catalyst 2.0 is to"
+ ewarn "supercede catalyst 1.x in every way. It is currently slotted for"
+ ewarn "testing purposes only."
+ insinto /usr/lib/${PN}2/arch
+ doins arch/* || die "copying arch/*"
+ insinto /usr/lib/${PN}2/modules
+ doins modules/* || die "copying modules/*"
+ insinto /usr/lib/${PN}2/livecd/cdtar
+ doins livecd/cdtar/* || die "copying cdtar/*"
+ insinto /usr/lib/${PN}2/livecd/files
+ doins livecd/files/* || die "copying files/*"
+ for x in targets/*; do
+ exeinto /usr/lib/${PN}2/$x
+ doexe $x/* || die "copying ${x}"
+ done
+ exeinto /usr/lib/${PN}2
+ newexe catalyst catalyst2 || die "copying catalyst"
+ dodir /usr/bin
+ dosym /usr/lib/${PN}2/catalyst2 /usr/bin/catalyst2
+ insinto /etc/catalyst2
+ newins files/catalyst.conf catalyst2.conf
+ DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+ dodoc README ChangeLog ChangeLog.old AUTHORS
+ newman files/catalyst.1 catalyst2.1
+ # This will go away in the future
+ dosed "s:/usr/lib/catalyst:/usr/lib/catalyst2:" \
+ /etc/catalyst2/catalyst2.conf
+ dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
+ /etc/catalyst2/catalyst2.conf
+ # Here is where we actually enable ccache
+ use ccache && \
+ dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+ /etc/catalyst2/catalyst2.conf
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+ echo
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0_rc45-slot.patch b/dev-util/catalyst/files/catalyst-2.0_rc45-slot.patch
new file mode 100644
index 000000000000..1ffb8b3edfe6
--- /dev/null
+++ b/dev-util/catalyst/files/catalyst-2.0_rc45-slot.patch
@@ -0,0 +1,30 @@
+diff -urN catalyst-2.0_rc45.orig/catalyst catalyst-2.0_rc44/catalyst
+--- catalyst-2.0_rc45.orig/catalyst 2005-12-20 07:07:45.000000000 -0500
++++ catalyst-2.0_rc45/catalyst 2005-12-20 07:09:19.000000000 -0500
+@@ -51,10 +51,10 @@
+ myconf={}
+ config_file=""
+
+- confdefaults={ "storedir":"/var/tmp/catalyst",\
+- "sharedir":"/usr/share/catalyst","distdir":"/usr/portage/distfiles",\
++ confdefaults={ "storedir":"/var/tmp/catalyst2",\
++ "sharedir":"/usr/share/catalyst2","distdir":"/usr/portage/distfiles",\
+ "portdir":"/usr/portage","options":"",\
+- "snapshot_cache":"/var/tmp/catalyst/snapshot_cache",\
++ "snapshot_cache":"/var/tmp/catalyst2/snapshot_cache",\
+ "hash_function":"crc32"}
+
+ # first, try the one passed (presumably from the cmdline)
+@@ -69,9 +69,9 @@
+ sys.exit(1)
+
+ # next, try the default location
+- elif os.path.exists("/etc/catalyst/catalyst.conf"):
+- print "Using default Catalyst configuration file, /etc/catalyst/catalyst.conf"
+- config_file="/etc/catalyst/catalyst.conf"
++ elif os.path.exists("/etc/catalyst2/catalyst2.conf"):
++ print "Using default Catalyst configuration file, /etc/catalyst2/catalyst2.conf"
++ config_file="/etc/catalyst2/catalyst2.conf"
+
+ # can't find a config file (we are screwed), so bail out
+ else:
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0_rc45 b/dev-util/catalyst/files/digest-catalyst-2.0_rc45
new file mode 100644
index 000000000000..7193f2d5bf7a
--- /dev/null
+++ b/dev-util/catalyst/files/digest-catalyst-2.0_rc45
@@ -0,0 +1,3 @@
+MD5 9527aef124463694f86c38b29f97b2d0 catalyst-2.0_rc45.tar.bz2 864602
+RMD160 4b1ca5964ed0beabc1cafcebcd34c0346be625c4 catalyst-2.0_rc45.tar.bz2 864602
+SHA256 cdb1f37732714683dea2ba4d1a20b1919fcc3550630f93e4b875ce8d365cc086 catalyst-2.0_rc45.tar.bz2 864602