summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-06-05 17:44:48 +0000
committerMichael Weber <xmw@gentoo.org>2012-06-05 17:44:48 +0000
commit2325eec6f8b09418bc1a021c37f6cb2df76be632 (patch)
tree1637d37acf359da28549e8c53bd98bc6590fade3 /dev-util
parentMask dev-lang/perl-5.16 (diff)
downloadgentoo-2-2325eec6f8b09418bc1a021c37f6cb2df76be632.tar.gz
gentoo-2-2325eec6f8b09418bc1a021c37f6cb2df76be632.tar.bz2
gentoo-2-2325eec6f8b09418bc1a021c37f6cb2df76be632.zip
Version bump (thanks Paolo Pedroni, bug 419731)
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/skipfish/ChangeLog7
-rw-r--r--dev-util/skipfish/skipfish-2.07_beta.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-util/skipfish/ChangeLog b/dev-util/skipfish/ChangeLog
index 23c34abc7869..8d9183f249e3 100644
--- a/dev-util/skipfish/ChangeLog
+++ b/dev-util/skipfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/skipfish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.9 2012/05/14 16:21:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/ChangeLog,v 1.10 2012/06/05 17:44:48 xmw Exp $
+
+*skipfish-2.07_beta (05 Jun 2012)
+
+ 05 Jun 2012; Michael Weber <xmw@gentoo.org> +skipfish-2.07_beta.ebuild:
+ Version bump (thanks Paolo Pedroni, bug 419731)
*skipfish-2.06_beta (14 May 2012)
diff --git a/dev-util/skipfish/skipfish-2.07_beta.ebuild b/dev-util/skipfish/skipfish-2.07_beta.ebuild
new file mode 100644
index 000000000000..828ea793a9a8
--- /dev/null
+++ b/dev-util/skipfish/skipfish-2.07_beta.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/skipfish/skipfish-2.07_beta.ebuild,v 1.1 2012/06/05 17:44:48 xmw Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A fully automated, active web application security reconnaissance tool"
+HOMEPAGE="http://code.google.com/p/skipfish/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tgz"
+
+LICENSE="Apache-2.0 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/openssl:0
+ net-dns/libidn
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/CFLAGS_GEN/s:-g -ggdb::' \
+ -e '/CFLAGS_OPT/s:-O3::' \
+ Makefile || die
+
+ sed -i \
+ -e "/ASSETS_DIR/s:assets:/usr/share/doc/${PF}/html:" \
+ config.h || die
+}
+
+src_compile() {
+ tc-export CC
+
+ local _debug
+ use debug && _debug=debug
+
+ emake ${_debug}
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ insinto /usr/share/${PN}/dictionaries
+ doins dictionaries/*.wl
+
+ dohtml assets/*
+
+ dodoc ChangeLog dictionaries/README-FIRST README
+}