summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-08-30 09:55:34 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-08-30 09:55:34 +0000
commit01ebbbdeae2d5270faf1de7942bd028c3c268e3c (patch)
treee5c1d030077b5ad8b48fe15f9276f5f461b56e55 /dev-util
parentVersion bump dev-haskell/gtk2hs. (diff)
downloadgentoo-2-01ebbbdeae2d5270faf1de7942bd028c3c268e3c.tar.gz
gentoo-2-01ebbbdeae2d5270faf1de7942bd028c3c268e3c.tar.bz2
gentoo-2-01ebbbdeae2d5270faf1de7942bd028c3c268e3c.zip
Make darcs-2.0.2 build with the most recent GHC version, and fix bug #282661.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/darcs/ChangeLog10
-rw-r--r--dev-util/darcs/darcs-2.0.2.ebuild17
-rw-r--r--dev-util/darcs/files/darcs-2.0.2-add-dummy-base-dependency.diff13
3 files changed, 35 insertions, 5 deletions
diff --git a/dev-util/darcs/ChangeLog b/dev-util/darcs/ChangeLog
index b99c5ff1c689..2902a2d9170f 100644
--- a/dev-util/darcs/ChangeLog
+++ b/dev-util/darcs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/darcs
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.103 2009/07/25 13:19:17 kolmodin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.104 2009/08/30 09:55:34 kolmodin Exp $
+
+ 30 Aug 2009; Lennart Kolmodin <kolmodin@gentoo.org> darcs-2.0.2.ebuild:
+ Fix build system so that it builds with ghc 6.10, as this is the latest
+ stable package and thus is the default to users running stable systems.
+ Patch by Sergei Trofimovich <slyfox@inbox.ru>.
+ Also add sys-libs/zlib as dep, to fix bug #282661.
25 Jul 2009; Lennart Kolmodin <kolmodin@gentoo.org> darcs-2.2.1.ebuild:
When building with USE=doc, make sure we have >=haddock-2.4.1.
diff --git a/dev-util/darcs/darcs-2.0.2.ebuild b/dev-util/darcs/darcs-2.0.2.ebuild
index cf68a44fe243..44c7bced5b3f 100644
--- a/dev-util/darcs/darcs-2.0.2.ebuild
+++ b/dev-util/darcs/darcs-2.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-2.0.2.ebuild,v 1.7 2008/10/18 18:05:50 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-2.0.2.ebuild,v 1.8 2009/08/30 09:55:34 kolmodin Exp $
-inherit base autotools eutils
+inherit base autotools eutils ghc-package
DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
HOMEPAGE="http://darcs.net"
@@ -23,6 +23,7 @@ DEPEND=">=net-misc/curl-7.10.2
dev-haskell/parsec
dev-haskell/regex-compat
sys-apps/diffutils
+ sys-libs/zlib
doc? ( virtual/latex-base
>=dev-tex/latex2html-2002.2.1_pre20041025-r1 )"
@@ -44,6 +45,7 @@ pkg_setup() {
src_unpack() {
base_src_unpack
+ epatch "${FILESDIR}/${PN}-2.0.2-add-dummy-base-dependency.diff"
cd "${S}/tools"
epatch "${FILESDIR}/${PN}-1.0.9-bashcomp.patch"
@@ -51,7 +53,16 @@ src_unpack() {
# of the low level ghc/gcc interaction gubbins.
use ia64 && sed -i 's/-funfolding-use-threshold20//' "${S}/GNUmakefile"
+ sed -i 's/-Werror//' "${S}/GNUmakefile"
+
+ #emulate: CABAL_CONFIGURE_FLAGS="--constraint=base<4"
+ # ghc-6.4: base-1; ghc-6.6.1: base-2; ghc-6.8: base-3; ghc-6.10: base-3, base-4
+ base_version="$($(ghc-getghcpkg) list --simple-output | tr " " "\n" | egrep '^base-[1-3]')"
+ sed -i "s@, base ,@, $base_version ,@" "${S}/aclocal.m4"
+ sed -i "s@-package base @-package $base_version @" "${S}/autoconf.mk.in"
+
cd "${S}"
+ sed -i 's/-Werror//' "${S}/aclocal.m4"
# Since we've patched the build system:
eautoreconf
}
diff --git a/dev-util/darcs/files/darcs-2.0.2-add-dummy-base-dependency.diff b/dev-util/darcs/files/darcs-2.0.2-add-dummy-base-dependency.diff
new file mode 100644
index 000000000000..af5c7ff1a541
--- /dev/null
+++ b/dev-util/darcs/files/darcs-2.0.2-add-dummy-base-dependency.diff
@@ -0,0 +1,13 @@
+diff --git a/autoconf.mk.in b/autoconf.mk.in
+index 86e0932..de4bdcf 100644
+--- a/autoconf.mk.in
++++ b/autoconf.mk.in
+@@ -24,7 +24,7 @@ LDFLAGS := @LDFLAGS@
+ OPTLLDFLAGS := $(addprefix -optl,$(LDFLAGS))
+ LIBS := @LIBS@
+ OPTLLIBS := $(filter-out -%,$(LIBS)) $(addprefix -optl,$(filter -%,$(LIBS)))
+-GHCFLAGS := @GHCFLAGS@ @CPPFLAGS@ @DEFS@
++GHCFLAGS := -package base @GHCFLAGS@ @CPPFLAGS@ @DEFS@
+ USE_GNULIBSHA1 := @USE_GNULIBSHA1@
+ HAVE_HTTP := @HAVE_HTTP@
+ HAVE_CURSES := @HAVE_CURSES@