summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-08 16:43:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-08 16:43:18 +0000
commitb13149dc4e8096649ef1a4ef99bce7fa2e996a5c (patch)
tree28b0b57dd3379bf174fc472815054f2a7a3cc668 /dev-util/valkyrie
parentStable on ppc64; bug #135027 (diff)
downloadgentoo-2-b13149dc4e8096649ef1a4ef99bce7fa2e996a5c.tar.gz
gentoo-2-b13149dc4e8096649ef1a4ef99bce7fa2e996a5c.tar.bz2
gentoo-2-b13149dc4e8096649ef1a4ef99bce7fa2e996a5c.zip
Add a patch to fix the few warnings spawning (fixes one format string error, maybe not vulnerability but always better to fix), and fix the path for documentation.
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'dev-util/valkyrie')
-rw-r--r--dev-util/valkyrie/ChangeLog8
-rw-r--r--dev-util/valkyrie/files/valkyrie-1.2.0-warnings.patch53
-rw-r--r--dev-util/valkyrie/valkyrie-1.2.0.ebuild14
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-util/valkyrie/ChangeLog b/dev-util/valkyrie/ChangeLog
index 0cdd4c1af4c9..66a0a6411916 100644
--- a/dev-util/valkyrie/ChangeLog
+++ b/dev-util/valkyrie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valkyrie
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.2 2006/06/08 12:05:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.3 2006/06/08 16:43:18 flameeyes Exp $
+
+ 08 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/valkyrie-1.2.0-warnings.patch, valkyrie-1.2.0.ebuild:
+ Add a patch to fix the few warnings spawning (fixes one format string error,
+ maybe not vulnerability but always better to fix), and fix the path for
+ documentation.
08 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> valkyrie-1.2.0.ebuild:
Add ~ppc (okay'd by lu_zero), and use emake for install.
diff --git a/dev-util/valkyrie/files/valkyrie-1.2.0-warnings.patch b/dev-util/valkyrie/files/valkyrie-1.2.0-warnings.patch
new file mode 100644
index 000000000000..7dccfe1e9407
--- /dev/null
+++ b/dev-util/valkyrie/files/valkyrie-1.2.0-warnings.patch
@@ -0,0 +1,53 @@
+Index: valkyrie-1.2.0/valkyrie/tool_utils/vglog.cpp
+===================================================================
+--- valkyrie-1.2.0.orig/valkyrie/tool_utils/vglog.cpp
++++ valkyrie-1.2.0/valkyrie/tool_utils/vglog.cpp
+@@ -863,7 +863,7 @@ bool VgLog::mergeErrors( VgErrorList sEr
+ {
+ VgErrCounts mErrCounts = errorcounts();
+
+- vklmPrint( 2, "--- update matches (n=%d) --- ", sErrors.count());
++ vklmPrint( 2, "--- update matches (n=%zu) --- ", sErrors.count());
+
+ /* --- find matches: update master err, delete slave err --- */
+
+@@ -927,7 +927,7 @@ bool VgLog::mergeErrors( VgErrorList sEr
+ vklmPrint( 2, " ");
+ }
+
+- vklmPrint( 2, "--- append non-matches (n=%d) --- ", sErrors.count() );
++ vklmPrint( 2, "--- append non-matches (n=%zu) --- ", sErrors.count() );
+
+ /* if no errcounts, and sErrors > 0, create empty errcounts */
+ if ( mErrCounts.isNull() && sErrors.count() > 0 ) {
+@@ -965,7 +965,7 @@ bool VgLog::mergeErrors( VgErrorList sEr
+
+ bool VgLog::mergeLeakErrors( VgErrorList sLeakErrors )
+ {
+- vklmPrint( 2, "--- update matches (n=%d) ---", sLeakErrors.count() );
++ vklmPrint( 2, "--- update matches (n=%zu) ---", sLeakErrors.count() );
+
+ /* --- for each leak in master --- */
+ VgErrorList errs = leaks();
+@@ -1001,7 +1001,7 @@ bool VgLog::mergeLeakErrors( VgErrorList
+ vklmPrint( 2, " ");
+ }
+
+- vklmPrint( 2, "--- append non-matches (n=%d) ---", sLeakErrors.count() );
++ vklmPrint( 2, "--- append non-matches (n=%zu) ---", sLeakErrors.count() );
+
+ /* --- append remaining slave leaks to master --- */
+ VgErrorList::Iterator sIt;
+Index: valkyrie-1.2.0/valkyrie/vk_file_utils.cpp
+===================================================================
+--- valkyrie-1.2.0.orig/valkyrie/vk_file_utils.cpp
++++ valkyrie-1.2.0/valkyrie/vk_file_utils.cpp
+@@ -3021,7 +3021,7 @@ void FileDialog::urlFinished( QNetworkOp
+ if ( d->paths->hasFocus() )
+ d->ignoreNextKeyPress = true;
+
+- vkWarn( this, "Error", op->protocolDetail().latin1() );
++ vkWarn( this, "Error", "%s", op->protocolDetail().latin1() );
+ switch ( op->errorCode() ) {
+ case QNetworkProtocol::ErrParse:
+ case QNetworkProtocol::ErrValid:
diff --git a/dev-util/valkyrie/valkyrie-1.2.0.ebuild b/dev-util/valkyrie/valkyrie-1.2.0.ebuild
index b0b72873108f..469c7c87aa91 100644
--- a/dev-util/valkyrie/valkyrie-1.2.0.ebuild
+++ b/dev-util/valkyrie/valkyrie-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/valkyrie-1.2.0.ebuild,v 1.2 2006/06/08 12:05:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/valkyrie-1.2.0.ebuild,v 1.3 2006/06/08 16:43:18 flameeyes Exp $
inherit eutils qt3
@@ -16,6 +16,13 @@ IUSE="debug"
DEPEND="$(qt_min_version 3)
>=dev-util/valgrind-3.2.0"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-warnings.patch"
+}
+
src_compile() {
use debug || sed -i -e '/#define DEBUG_ON/ s:1:0:' \
"${S}/valkyrie/vk_utils.h"
@@ -23,6 +30,11 @@ src_compile() {
econf \
--disable-dependency-tracking \
--with-Qt-dir="${QTDIR}" || die "econf failed"
+
+ # Use the right path for the documentation
+ sed -i -e '/VK_DOC_PATH/ s:/doc/:/share/doc/'${PF}'/html/:g' \
+ "${S}/config.h"
+
emake || die "emake failed"
}