summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2008-02-13 16:58:18 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2008-02-13 16:58:18 +0000
commit6cc4f2192689e51aefbbb974cd31cfc1df62c118 (patch)
tree87b85f631eb58027d2e3ff5dbfc269edfe2752ec /dev-util/stgit
parentCorrect e-mail address. (diff)
downloadgentoo-2-6cc4f2192689e51aefbbb974cd31cfc1df62c118.tar.gz
gentoo-2-6cc4f2192689e51aefbbb974cd31cfc1df62c118.tar.bz2
gentoo-2-6cc4f2192689e51aefbbb974cd31cfc1df62c118.zip
0.14 update
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-util/stgit')
-rw-r--r--dev-util/stgit/ChangeLog9
-rw-r--r--dev-util/stgit/stgit-0.14.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-util/stgit/ChangeLog b/dev-util/stgit/ChangeLog
index fe7410575dce..a031915050aa 100644
--- a/dev-util/stgit/ChangeLog
+++ b/dev-util/stgit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/stgit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.24 2007/08/11 10:24:34 ferdy Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/ChangeLog,v 1.25 2008/02/13 16:58:18 gregkh Exp $
+
+*stgit-0.14 (13 Feb 2008)
+
+ 13 Feb 2008; Greg Kroah-Hartman <gregkh@gentoo.org> +stgit-0.14.ebuild:
+ 0.14 version update
*stgit-0.13 (11 Aug 2007)
diff --git a/dev-util/stgit/stgit-0.14.ebuild b/dev-util/stgit/stgit-0.14.ebuild
new file mode 100644
index 000000000000..66646d59f334
--- /dev/null
+++ b/dev-util/stgit/stgit-0.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/stgit-0.14.ebuild,v 1.1 2008/02/13 16:58:18 gregkh Exp $
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://homepage.ntlworld.com/cmarinas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-util/git-1.5"
+
+src_install() {
+ sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
+ distutils_src_install
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/share/doc/${PN}
+ dobashcompletion contrib/stgit-completion.bash ${PN}
+}