summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-06 16:55:24 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-06 16:55:24 +0000
commit336f804e9cf443c73e41a1509b352f1067bcefb4 (patch)
treecdaebb38c21d771f00cddee7ec93af9ca93e8166 /dev-util/scons
parentRemove old. (diff)
downloadgentoo-2-336f804e9cf443c73e41a1509b352f1067bcefb4.tar.gz
gentoo-2-336f804e9cf443c73e41a1509b352f1067bcefb4.tar.bz2
gentoo-2-336f804e9cf443c73e41a1509b352f1067bcefb4.zip
Fix race condition in installing scripts, bug #455878.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-util/scons')
-rw-r--r--dev-util/scons/ChangeLog5
-rw-r--r--dev-util/scons/scons-2.2.0-r1.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 93a63a9b179d..95045e7a117d 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/scons
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.127 2013/02/06 12:22:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.128 2013/02/06 16:55:24 mgorny Exp $
+
+ 06 Feb 2013; Michał Górny <mgorny@gentoo.org> scons-2.2.0-r1.ebuild:
+ Fix race condition in installing scripts, bug #455878.
*scons-2.2.0-r1 (06 Feb 2013)
diff --git a/dev-util/scons/scons-2.2.0-r1.ebuild b/dev-util/scons/scons-2.2.0-r1.ebuild
index 63e5b416ee6e..7a5f7828c10d 100644
--- a/dev-util/scons/scons-2.2.0-r1.ebuild
+++ b/dev-util/scons/scons-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-2.2.0-r1.ebuild,v 1.1 2013/02/06 12:22:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-2.2.0-r1.ebuild,v 1.2 2013/02/06 16:55:24 mgorny Exp $
EAPI=5
@@ -39,10 +39,6 @@ python_install() {
--standard-lib \
--no-version-script \
--install-data "${EPREFIX}"/usr/share
-
- # Build system does not use build_scripts properly.
- # http://scons.tigris.org/issues/show_bug.cgi?id=2891
- python_doscript "${ED}"usr/bin/scons{,ign,-time}
}
python_install_all() {
@@ -50,4 +46,8 @@ python_install_all() {
distutils-r1_python_install_all
use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
+
+ # Build system does not use build_scripts properly.
+ # http://scons.tigris.org/issues/show_bug.cgi?id=2891
+ python_replicate_script "${ED}"usr/bin/scons{,ign,-time}
}