summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2005-08-15 18:56:16 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2005-08-15 18:56:16 +0000
commit6846b7dc9cb0c1a59fbd01b7cb4b5d0c15851c88 (patch)
tree00805593373e6373512d5a8bb93bd0ce965af488 /dev-util/eclipse-sdk
parentadded rpath patch, p.masked for further testing (diff)
downloadgentoo-2-6846b7dc9cb0c1a59fbd01b7cb4b5d0c15851c88.tar.gz
gentoo-2-6846b7dc9cb0c1a59fbd01b7cb4b5d0c15851c88.tar.bz2
gentoo-2-6846b7dc9cb0c1a59fbd01b7cb4b5d0c15851c88.zip
Fixes #100360.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-util/eclipse-sdk')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog6
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild54
2 files changed, 14 insertions, 46 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 0043af01a6a8..f5cd6f4ea50d 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.98 2005/07/24 17:03:17 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.99 2005/08/15 18:56:16 karltk Exp $
+
+ 15 Aug 2005; Karl Trygve Kalleberg <karltk@gentoo.org>
+ eclipse-sdk-3.1-r1.ebuild:
+ Fixes #100360.
24 Jul 2005; Karl Trygve Kalleberg <karltk@gentoo.org>
eclipse-sdk-3.1-r1.ebuild:
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild
index d82cec8a464e..864aeb116a04 100644
--- a/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild
+++ b/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild,v 1.6 2005/07/26 00:03:35 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1-r1.ebuild,v 1.7 2005/08/15 18:56:16 karltk Exp $
inherit eutils java-utils
@@ -75,12 +75,6 @@ src_unpack() {
einfo "Cleaning out prebuilt code"
clean-prebuilt-code
- einfo "Patching build"
- process-build
-
- einfo "Patching makefiles"
- process-makefiles
-
einfo "Patching makefiles"
process-makefiles
@@ -108,18 +102,20 @@ src_compile() {
einfo "Bootstrapping ecj"
ant -lib jdtcoresrc/ecj.jar -q -f jdtcoresrc/compilejdtcore.xml || die "Failed to bootstrap ecj"
-# einfo "Building launcher"
-# build-native
-# cp features/org.eclipse.platform.launchers/library/gtk/eclipse \
-# eclipse-gtk || die "Failed to copy launcher"
-
einfo "Compiling Eclipse -- see ${S}/compilelog.txt for details"
- ant -lib jdtcoresrc/ecj.jar -q -f build.xml \
+ ANT_OPTS="-Xmx1024M -XX:CompileThreshold=1500" \
+ ant -lib jdtcoresrc/ecj.jar -q -f build.xml \
-DinstallOs=linux \
-DinstallWs=gtk \
-DinstallArch=${eclipsearch} \
-Dbootclasspath=${bootclasspath} \
-Dlibsconfig=true \
+ -DjavacTarget=1.4 \
+ -DjavacSource=1.4 \
+ -DjavacVerbose=false \
+ -DjavacFailOnError=true \
+ -DjavacDebugInfo=true \
+ -DbuildId="Gentoo Linux ${PF}" \
|| die "Failed to compile Eclipse"
cp launchertmp/eclipse eclipse-gtk || die "Cannot find eclipse binary"
@@ -205,38 +201,6 @@ function setup-mozilla-opts()
export GECKO_LIBS="-L${GECKO_SDK} -lgtkembedmoz"
}
-function process-build() {
-
- local targetOptimization="1.4"
- local ant_opts="-Xmx1024M"
-
-# Eclipse has ~10 classes that do not yet compile with java 5.0
-# if (java-utils_is-vm-version-ge 1 5 0) ; then
-# targetOptimization="1.5"
-# fi
-
- einfo "Optimizing for Java ${targetOptimization} VM"
-
- # Some sun JVM's have only server VM and no client VM. To speed up things
- # use a same compiler threshold that client VM defaults to
- if [ ! -z "`java-config --java-version | fgrep "Server VM"`" ] ; then
- ant_opts="${ant_opts} -XX:CompileThreshold=1500"
- fi
-
- # Eclipse has started to respect global flags so patching the main build is enough
- local properties="-DjavacTarget=${targetOptimization} \
- -DjavacSource=${targetOptimization} \
- -DjavacVerbose=false \
- -DjavacFailOnError=true \
- -DjavacDebugInfo=true \
- -DbuildId=\"Gentoo Linux ${PF}\""
-
- sed \
- -e "s/ant -q /ant -q ${properties} /" \
- -e "s/ANT_OPTS=-Xmx1000M/ANT_OPTS=\"${ant_opts}\"/" \
- -i build || die "Failed to patch build script"
-}
-
function build-native() {
sh features/org.eclipse.platform.launchers/library/gtk/build.sh \
-os linux -ws gtk \