summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-09-19 15:12:37 +0000
committerDaniel Drake <dsd@gentoo.org>2006-09-19 15:12:37 +0000
commitc854f809ae96c1eacbc43df06652c8a927dbc969 (patch)
tree6d5d60672c7b59cfcad85666c6edccfc53e692ee /dev-util/acgmake/acgmake-1.2-r1.ebuild
parentInitial import based on ebuild by Seemant Kulleen, thanks to ville in bug #12... (diff)
downloadgentoo-2-c854f809ae96c1eacbc43df06652c8a927dbc969.tar.gz
gentoo-2-c854f809ae96c1eacbc43df06652c8a927dbc969.tar.bz2
gentoo-2-c854f809ae96c1eacbc43df06652c8a927dbc969.zip
Fix permissions of installed files
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-util/acgmake/acgmake-1.2-r1.ebuild')
-rw-r--r--dev-util/acgmake/acgmake-1.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/acgmake/acgmake-1.2-r1.ebuild b/dev-util/acgmake/acgmake-1.2-r1.ebuild
new file mode 100644
index 000000000000..1844bccb1955
--- /dev/null
+++ b/dev-util/acgmake/acgmake-1.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/acgmake/acgmake-1.2-r1.ebuild,v 1.1 2006/09/19 15:12:37 dsd Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Build system for large projects"
+HOMEPAGE="http://www-i8.informatik.rwth-aachen.de/software/acgmake/html/index.html"
+SRC_URI="http://www-i8.informatik.rwth-aachen.de/software/acgmake/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-shells/bash
+ sys-devel/make"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ find . -name 'CVS' -type d -print0 | xargs -0 rm -rf
+ sed -i "s:g++.*:g++:" configs/config.gcc-linux
+ chmod 644 ${S}/configs/*
+ chmod 644 ${S}/modules/*
+}
+
+src_install() {
+ insinto /usr/lib/misc/acgmake
+ doins Config Rules
+ cp -a bin configs modules ${D}/usr/lib/misc/acgmake
+
+ dosym ../lib/misc/acgmake/bin/acgmake /usr/bin/acgmake
+}
+