summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-10-11 22:18:40 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-10-11 22:18:40 +0000
commit82b3aa6e9eda4bd09930d5c69b4b1cf29e531dfe (patch)
tree2400634779f67049c22c1e61b9ee43d52dfe5054 /dev-tex/latexmk/latexmk-418.ebuild
parentarm stable, bug #337139 (diff)
downloadgentoo-2-82b3aa6e9eda4bd09930d5c69b4b1cf29e531dfe.tar.gz
gentoo-2-82b3aa6e9eda4bd09930d5c69b4b1cf29e531dfe.tar.bz2
gentoo-2-82b3aa6e9eda4bd09930d5c69b4b1cf29e531dfe.zip
Version bump
(Portage version: 2.1.9.14/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/latexmk/latexmk-418.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-418.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-418.ebuild b/dev-tex/latexmk/latexmk-418.ebuild
new file mode 100644
index 000000000000..c6940d862ecc
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-418.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-418.ebuild,v 1.1 2010/10/11 22:18:40 dilfridge Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_install() {
+ cd "${WORKDIR}"
+ newbin latexmk.pl latexmk || die
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt || die
+ doman latexmk.1 || die
+ insinto /usr/share/doc/${PF}
+ doins -r example_rcfiles extra-scripts || die
+ dobashcompletion "${FILESDIR}"/completion.bash ${PN}
+}