summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-06-03 14:20:23 +0000
committerUlrich Müller <ulm@gentoo.org>2009-06-03 14:20:23 +0000
commitd055949d53d3f592d33f07efe53bcb48480d74f9 (patch)
tree43eeb5ae58031dec9bddfaebcaec19f933f887c6 /dev-tex/dvi2tty
parentMarking kmoon-3.5.10 ppc64 for bug 271889 (diff)
downloadgentoo-2-d055949d53d3f592d33f07efe53bcb48480d74f9.tar.gz
gentoo-2-d055949d53d3f592d33f07efe53bcb48480d74f9.tar.bz2
gentoo-2-d055949d53d3f592d33f07efe53bcb48480d74f9.zip
Fix compilation with glibc-2.10 headers, bug 271621.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-tex/dvi2tty')
-rw-r--r--dev-tex/dvi2tty/ChangeLog9
-rw-r--r--dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild5
-rw-r--r--dev-tex/dvi2tty/files/dvi2tty-getline.patch67
3 files changed, 77 insertions, 4 deletions
diff --git a/dev-tex/dvi2tty/ChangeLog b/dev-tex/dvi2tty/ChangeLog
index 756b49bec0fd..39be2d955279 100644
--- a/dev-tex/dvi2tty/ChangeLog
+++ b/dev-tex/dvi2tty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/dvi2tty
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/dvi2tty/ChangeLog,v 1.21 2009/03/18 19:30:02 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dvi2tty/ChangeLog,v 1.22 2009/06/03 14:20:22 ulm Exp $
+
+ 03 Jun 2009; Ulrich Mueller <ulm@gentoo.org> +files/dvi2tty-getline.patch,
+ dvi2tty-5.3.1.ebuild:
+ Fix compilation with glibc-2.10 headers. Thanks to <hirakendu@gmail.com>
+ in bug 271621.
18 Mar 2009; Raúl Porcel <armin76@gentoo.org> dvi2tty-5.3.1.ebuild:
arm/s390/sh stable wrt #253551
diff --git a/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild b/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild
index 4379f45f5819..08c7eebdb834 100644
--- a/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild
+++ b/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild,v 1.18 2009/03/18 19:30:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dvi2tty/dvi2tty-5.3.1.ebuild,v 1.19 2009/06/03 14:20:22 ulm Exp $
inherit eutils toolchain-funcs
DESCRIPTION="Preview dvi-files on text-only devices"
HOMEPAGE="http://www.ctan.org/tex-archive/dviware/"
SRC_URI="ftp://ftp.mesa.nl/pub/dvi2tty/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND=""
src_unpack() {
unpack ${A}
epatch "${FILESDIR}/${PN}-gcc.patch"
epatch "${FILESDIR}/${PN}-cflags.patch"
+ epatch "${FILESDIR}/${PN}-getline.patch"
}
src_compile() {
diff --git a/dev-tex/dvi2tty/files/dvi2tty-getline.patch b/dev-tex/dvi2tty/files/dvi2tty-getline.patch
new file mode 100644
index 000000000000..932810ea40a5
--- /dev/null
+++ b/dev-tex/dvi2tty/files/dvi2tty-getline.patch
@@ -0,0 +1,67 @@
+http://bugs.gentoo.org/271621
+
+--- dvi2tty-5.3.1-orig/dvistuff.c 2003-01-23 04:01:12.000000000 +0100
++++ dvi2tty-5.3.1/dvistuff.c 2009-06-03 15:57:26.000000000 +0200
+@@ -179,7 +179,7 @@
+ void ruleaux (long, long, char);
+ long horizontalmove (long);
+ int skipnops (void);
+-linetype * getline (void);
++linetype * get_line (void);
+ linetype * findline (void);
+ unsigned long num (int);
+ long snum (int);
+@@ -208,7 +208,7 @@
+ void ruleaux (long rulewt, long ruleht, char ch);
+ long horizontalmove (long amount);
+ int skipnops (void);
+-linetype * getline (void);
++linetype * get_line (void);
+ linetype * findline (void);
+ unsigned long num (int size);
+ long snum (int size);
+@@ -376,7 +376,7 @@
+ h = 0L; v = 0L; /* initialize coordinates */
+ x = 0L; w = 0L; y = 0L; z = 0L; /* initialize amounts */
+ sptr = 0; /* initialize stack */
+- currentline = getline(); /* initialize list of lines */
++ currentline = get_line(); /* initialize list of lines */
+ currentline->vv = 0L;
+ firstline = currentline;
+ lastline = currentline;
+@@ -777,7 +777,7 @@
+ * GETLINE -- Returns an initialized line-object
+ */
+
+-linetype *getline(void)
++linetype *get_line(void)
+ {
+ register int i;
+ register linetype *temp;
+@@ -809,7 +809,7 @@
+
+ if (v <= firstline->vv) { /* above first line */
+ if (firstline->vv - v > lineheight) {
+- temp = getline();
++ temp = get_line();
+ temp->next = firstline;
+ firstline->prev = temp;
+ temp->vv = v;
+@@ -820,7 +820,7 @@
+
+ if (v >= lastline->vv) { /* below last line */
+ if (v - lastline->vv > lineheight) {
+- temp = getline();
++ temp = get_line();
+ temp->prev = lastline;
+ lastline->next = temp;
+ temp->vv = v;
+@@ -843,7 +843,7 @@
+ return temp->next;
+
+ /* no line fits suitable, generate a new one */
+- currentline = getline();
++ currentline = get_line();
+ currentline->next = temp->next;
+ currentline->prev = temp;
+ temp->next->prev = currentline;