summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-05-18 19:53:36 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-05-18 19:53:36 +0000
commit173a2424db96b2e61899114484aa17c755a6dccb (patch)
tree32ccf2b7d754bd4b926611153dbc1113d4ba46da /dev-scheme
parentamd64/x86 stable, bug #221063 (diff)
downloadgentoo-2-173a2424db96b2e61899114484aa17c755a6dccb.tar.gz
gentoo-2-173a2424db96b2e61899114484aa17c755a6dccb.tar.bz2
gentoo-2-173a2424db96b2e61899114484aa17c755a6dccb.zip
bump
(Portage version: 2.1.5)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/stklos/ChangeLog9
-rw-r--r--dev-scheme/stklos/stklos-0.98.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-scheme/stklos/ChangeLog b/dev-scheme/stklos/ChangeLog
index 28f2707b61d7..6a6df3a0ee71 100644
--- a/dev-scheme/stklos/ChangeLog
+++ b/dev-scheme/stklos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/stklos
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.7 2007/12/16 12:51:11 hkbst Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/ChangeLog,v 1.8 2008/05/18 19:53:36 hkbst Exp $
+
+*stklos-0.98 (18 May 2008)
+
+ 18 May 2008; Marijn Schouten <hkBst@gentoo.org> +stklos-0.98.ebuild:
+ bump
*stklos-0.97 (16 Dec 2007)
diff --git a/dev-scheme/stklos/stklos-0.98.ebuild b/dev-scheme/stklos/stklos-0.98.ebuild
new file mode 100644
index 000000000000..130ab740a9d4
--- /dev/null
+++ b/dev-scheme/stklos/stklos-0.98.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/stklos/stklos-0.98.ebuild,v 1.1 2008/05/18 19:53:36 hkbst Exp $
+
+inherit eutils
+
+DESCRIPTION="fast and light Scheme implementation"
+HOMEPAGE="http://www.stklos.org"
+SRC_URI="http://www.stklos.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads ldap gtk gnome"
+DEPEND="dev-libs/gmp dev-libs/libpcre dev-libs/boehm-gc
+ ldap? ( net-nds/openldap )
+ gtk? ( x11-libs/gtk+ )"
+# gnome? ( )" # someone using gnome should figure out what package will enable gnome support
+#silex and ``The Dominique Boucher LALR Package'' may also be deps, not in tree though
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use threads; then
+ built_with_use dev-libs/boehm-gc threads || die "boehm-gc must be built with threads use flag"
+ fi
+}
+
+src_compile() {
+#anyone interested in lurc threads? not in tree though
+#disable ffi while only bundled can be used
+ econf $(use_enable threads threads pthreads) $(use_enable ldap) $(use_enable gtk) $(use_enable gnome) \
+ --without-gmp-light --without-provided-gc --without-provided-regexp --disable-ffi
+# $(use_enable ffi) \
+ emake || die "emake failed"
+}
+
+# call/cc & dynamic-wind test fails on amd64. already upstream
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}