summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-24 00:02:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-24 00:02:35 +0000
commit21ed7563764ccdcc885bdf61b9c6a39d07d46510 (patch)
tree3518eab39076ca2e88443af70b09c3888ae4b194 /dev-ruby
parentDefine each_ruby_test in ruby-fakegem only if a test task is defined. (diff)
downloadgentoo-2-21ed7563764ccdcc885bdf61b9c6a39d07d46510.tar.gz
gentoo-2-21ed7563764ccdcc885bdf61b9c6a39d07d46510.tar.bz2
gentoo-2-21ed7563764ccdcc885bdf61b9c6a39d07d46510.zip
Cleanup, set the fakegem name, so that the spec file is generated correctly, also add ruby19 support and install also the .rb glue file.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-serialport/ChangeLog7
-rw-r--r--dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild32
2 files changed, 29 insertions, 10 deletions
diff --git a/dev-ruby/ruby-serialport/ChangeLog b/dev-ruby/ruby-serialport/ChangeLog
index 5e765863c627..ed346a3cbe8e 100644
--- a/dev-ruby/ruby-serialport/ChangeLog
+++ b/dev-ruby/ruby-serialport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-serialport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.10 2010/01/23 07:36:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ChangeLog,v 1.11 2010/01/24 00:02:35 flameeyes Exp $
+
+ 24 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ ruby-serialport-1.0.1.ebuild:
+ Cleanup, set the fakegem name, so that the spec file is generated
+ correctly, also add ruby19 support and install also the .rb glue file.
*ruby-serialport-1.0.1 (23 Jan 2010)
diff --git a/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild b/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild
index d53622d2bb4c..f62aecd17584 100644
--- a/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild
+++ b/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild
@@ -1,38 +1,52 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild,v 1.1 2010/01/23 07:36:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-serialport/ruby-serialport-1.0.1.ebuild,v 1.2 2010/01/24 00:02:35 flameeyes Exp $
EAPI="2"
-USE_RUBY="ruby18"
+
+# jruby → uses native library
+USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_NAME=${PN/ruby-/}
+
inherit ruby-fakegem
-MY_P=${P/ruby-/}
DESCRIPTION="a library for serial port (rs232) access in ruby"
HOMEPAGE="http://rubyforge.org/projects/ruby-serialport/"
-SRC_URI="mirror://rubygems/${MY_P}.gem"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ia64 ~ppc ~x86"
IUSE=""
+all_ruby_prepare() {
+ # Fix the miniterm script so that it might actually work, we'll
+ # install it as example.
+ sed -i -e 's:\.\./serialport.so:serialport:' test/miniterm.rb || die
+}
+
each_ruby_configure() {
cd ext/native
${RUBY} extconf.rb || die
}
each_ruby_compile() {
- cd ext/native
+ pushd ext/native &>/dev/null
emake || die
+ popd &>/dev/null
+
+ # Avoids the need for a specific install phase
+ cp ext/native/*.so lib/ || die "extension copy failed"
}
-each_ruby_install() {
- ruby_fakegem_genspec
+all_ruby_install() {
+ all_fakegem_install
- cd ext/native
- emake DESTDIR="${D}" install || die
+ docinto examples
+ # don't compress it
+ doins test/miniterm.rb || die
}