summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-01-21 14:50:40 +0000
committerAron Griffis <agriffis@gentoo.org>2002-01-21 14:50:40 +0000
commit7c86eee6bcc2bc37f4d6b5c9cd2067e402f6b6a4 (patch)
tree49fdd7fd9fdacf51f74b4ae9f21b36fcef14cf6e /dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild
parentdisabled opengl scrensavers until libGL.la bug is fixed (an opegl problem, no... (diff)
downloadgentoo-2-7c86eee6bcc2bc37f4d6b5c9cd2067e402f6b6a4.tar.gz
gentoo-2-7c86eee6bcc2bc37f4d6b5c9cd2067e402f6b6a4.tar.bz2
gentoo-2-7c86eee6bcc2bc37f4d6b5c9cd2067e402f6b6a4.zip
Added ebuilds for ruby bindings to Gtk+ and Gnome.
Diffstat (limited to 'dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild')
-rw-r--r--dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild b/dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild
new file mode 100644
index 000000000000..04cc24bbcf96
--- /dev/null
+++ b/dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ruby-gconf-0.1.ebuild,v 1.1 2002/01/21 14:50:40 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ruby Gconf bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/${P}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=gnome-base/gconf-1.0.7-r2"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make install DESTDIR=${D}
+ dodoc [A-Z]*
+}