summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-16 15:34:20 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-16 15:34:20 +0000
commit89abc40e7339de2c13e9f054371b9a32340e1c59 (patch)
treefc5753145005176b5c5ffd023936c50eb1aab8d6 /dev-ruby/fattr
parentVersion bump. (diff)
downloadgentoo-2-89abc40e7339de2c13e9f054371b9a32340e1c59.tar.gz
gentoo-2-89abc40e7339de2c13e9f054371b9a32340e1c59.tar.bz2
gentoo-2-89abc40e7339de2c13e9f054371b9a32340e1c59.zip
Version bump. Add ruby21 target.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/fattr')
-rw-r--r--dev-ruby/fattr/ChangeLog9
-rw-r--r--dev-ruby/fattr/fattr-2.2.2.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-ruby/fattr/ChangeLog b/dev-ruby/fattr/ChangeLog
index 8b25b272c55b..c9b091b5bffd 100644
--- a/dev-ruby/fattr/ChangeLog
+++ b/dev-ruby/fattr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fattr
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/ChangeLog,v 1.13 2013/11/02 20:22:22 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/ChangeLog,v 1.14 2014/02/16 15:34:20 mrueg Exp $
+
+*fattr-2.2.2 (16 Feb 2014)
+
+ 16 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +fattr-2.2.2.ebuild:
+ Version bump. Add ruby21 target.
02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -fattr-2.2.1.ebuild:
Cleanup old.
diff --git a/dev-ruby/fattr/fattr-2.2.2.ebuild b/dev-ruby/fattr/fattr-2.2.2.ebuild
new file mode 100644
index 000000000000..5b5f82555122
--- /dev/null
+++ b/dev-ruby/fattr/fattr-2.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/fattr-2.2.2.ebuild,v 1.1 2014/02/16 15:34:20 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="fattr.rb is a \"fatter attr\" for ruby."
+HOMEPAGE="http://rubyforge.org/projects/codeforpeople/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} test/fattr_test.rb || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}