summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-12 20:10:38 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-12 20:10:38 +0000
commitc07abeb1593d18f9a21a877dc0ec29f9334aa8cf (patch)
tree61bddb0bb34c9c56e976385381a145418f2193cf /dev-ruby/allison
parentRemove app-forensics/samhain & virtual/gnus masks. Removed from tree. (diff)
downloadgentoo-2-c07abeb1593d18f9a21a877dc0ec29f9334aa8cf.tar.gz
gentoo-2-c07abeb1593d18f9a21a877dc0ec29f9334aa8cf.tar.bz2
gentoo-2-c07abeb1593d18f9a21a877dc0ec29f9334aa8cf.zip
Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/allison')
-rw-r--r--dev-ruby/allison/ChangeLog7
-rw-r--r--dev-ruby/allison/allison-2.0.3-r1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/allison/ChangeLog b/dev-ruby/allison/ChangeLog
index 5988936906c1..c2d8d05efa4e 100644
--- a/dev-ruby/allison/ChangeLog
+++ b/dev-ruby/allison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/allison
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/ChangeLog,v 1.10 2010/05/22 15:01:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/ChangeLog,v 1.11 2010/06/12 20:10:38 graaff Exp $
+
+*allison-2.0.3-r1 (12 Jun 2010)
+
+ 12 Jun 2010; Hans de Graaff <graaff@gentoo.org> +allison-2.0.3-r1.ebuild:
+ Convert to ruby-fakegem.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
allison-2.0.3.ebuild:
diff --git a/dev-ruby/allison/allison-2.0.3-r1.ebuild b/dev-ruby/allison/allison-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..58367db0df01
--- /dev/null
+++ b/dev-ruby/allison/allison-2.0.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/allison-2.0.3-r1.ebuild,v 1.1 2010/06/12 20:10:38 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_EXTRAINSTALL="cache"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A modern, pretty RDoc template."
+HOMEPAGE="http://blog.evanweaver.com/files/doc/fauna/allison/files/README.html"
+
+LICENSE="AFL-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+}