summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-29 08:54:24 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-29 08:54:24 +0000
commit21e2ba569573b52b016da0894b5c912e1df047e3 (patch)
tree4423ef4dd229ac538bc43377abda8f1396c32a53 /dev-python
parentAdd ~amd64, wrt bug #440056 (diff)
downloadgentoo-2-21e2ba569573b52b016da0894b5c912e1df047e3.tar.gz
gentoo-2-21e2ba569573b52b016da0894b5c912e1df047e3.tar.bz2
gentoo-2-21e2ba569573b52b016da0894b5c912e1df047e3.zip
Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/decorator/ChangeLog8
-rw-r--r--dev-python/decorator/decorator-3.4.0.ebuild35
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index 79820c1dd401..06608e16c1ee 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.56 2012/09/30 17:03:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.57 2012/10/29 08:54:24 patrick Exp $
+
+*decorator-3.4.0 (29 Oct 2012)
+
+ 29 Oct 2012; Patrick Lauer <patrick@gentoo.org> +decorator-3.4.0.ebuild:
+ Bump
30 Sep 2012; Raúl Porcel <armin76@gentoo.org> decorator-3.3.1.ebuild,
decorator-3.3.2.ebuild, decorator-3.3.3.ebuild:
@@ -209,4 +214,3 @@
02 May 2008; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
+decorator-2.2.0.ebuild:
Initial commit. Thanks Qiangning Hong <hongqn@gmail.com> bug #176640
-
diff --git a/dev-python/decorator/decorator-3.4.0.ebuild b/dev-python/decorator/decorator-3.4.0.ebuild
new file mode 100644
index 000000000000..8fb5b909518f
--- /dev/null
+++ b/dev-python/decorator/decorator-3.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.4.0.ebuild,v 1.1 2012/10/29 08:54:24 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_TESTS_RESTRICTED_ABIS="2.4 2.5"
+
+inherit distutils
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator http://code.google.com/p/micheles/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="README.txt"
+PYTHON_MODNAME="decorator.py"
+
+src_test() {
+ testing() {
+ if [[ "${PYTHON_ABI}" == 3.* ]]; then
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation3.py
+ else
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation.py
+ fi
+ }
+ python_execute_function testing
+}