summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-04 20:18:21 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-04 20:18:21 +0000
commitc4c5b132ac38f45786c5f9f90726c1bff00a2302 (patch)
treecbfb0e8dad7e36f7636692ef4ec1c8c1ff9d8e92 /dev-python/sqlitecachec
parentimprove handling of DOCS variable wrt #468092 (diff)
downloadgentoo-2-c4c5b132ac38f45786c5f9f90726c1bff00a2302.tar.gz
gentoo-2-c4c5b132ac38f45786c5f9f90726c1bff00a2302.tar.bz2
gentoo-2-c4c5b132ac38f45786c5f9f90726c1bff00a2302.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/sqlitecachec')
-rw-r--r--dev-python/sqlitecachec/ChangeLog9
-rw-r--r--dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/sqlitecachec/ChangeLog b/dev-python/sqlitecachec/ChangeLog
index 86532c93c10a..a09a72b3da83 100644
--- a/dev-python/sqlitecachec/ChangeLog
+++ b/dev-python/sqlitecachec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sqlitecachec
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlitecachec/ChangeLog,v 1.5 2012/05/04 15:12:17 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlitecachec/ChangeLog,v 1.6 2013/05/04 20:18:21 floppym Exp $
+
+*sqlitecachec-1.1.4-r1 (04 May 2013)
+
+ 04 May 2013; Mike Gilbert <floppym@gentoo.org> +sqlitecachec-1.1.4-r1.ebuild:
+ Convert to distutils-r1.
04 May 2012; Patrick Lauer <patrick@gentoo.org> sqlitecachec-1.1.4.ebuild:
Migrating dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
new file mode 100644
index 000000000000..95e593d92d5e
--- /dev/null
+++ b/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sqlitecachec/sqlitecachec-1.1.4-r1.ebuild,v 1.1 2013/05/04 20:18:21 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P="yum-metadata-parser-${PV}"
+
+DESCRIPTION="sqlite cacher for python applications"
+HOMEPAGE="http://yum.baseurl.org/"
+SRC_URI="http://yum.baseurl.org/download/yum-metadata-parser/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# glib and libxml2 are used via an extension module written in C.
+# No need to add PYTHON_USEDEP here.
+RDEPEND="dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"