summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-25 09:12:46 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-25 09:12:46 +0000
commitd811e91fff429c09be525f2b499748917673e388 (patch)
treed5ca008b70a05ea17775e76a656840c3e9dee0eb /dev-python/sip
parentmigrate to git-2 eclass (diff)
downloadgentoo-2-d811e91fff429c09be525f2b499748917673e388.tar.gz
gentoo-2-d811e91fff429c09be525f2b499748917673e388.tar.bz2
gentoo-2-d811e91fff429c09be525f2b499748917673e388.zip
revbump to use the new python3.2 patch
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog8
-rw-r--r--dev-python/sip/files/sip-4.12.3-python-3.2.patch80
-rw-r--r--dev-python/sip/sip-4.12.3-r2.ebuild (renamed from dev-python/sip/sip-4.12.3-r1.ebuild)2
3 files changed, 71 insertions, 19 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 19440d482cdc..f38aec507b9f 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.194 2011/06/24 20:39:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.195 2011/06/25 09:12:46 hwoarang Exp $
+
+*sip-4.12.3-r2 (25 Jun 2011)
+
+ 25 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -sip-4.12.3-r1.ebuild,
+ +sip-4.12.3-r2.ebuild, files/sip-4.12.3-python-3.2.patch:
+ revbump to use the new python3.2 patch
*sip-4.12.3-r1 (24 Jun 2011)
diff --git a/dev-python/sip/files/sip-4.12.3-python-3.2.patch b/dev-python/sip/files/sip-4.12.3-python-3.2.patch
index fcad6a08afe6..b0bdaed021c9 100644
--- a/dev-python/sip/files/sip-4.12.3-python-3.2.patch
+++ b/dev-python/sip/files/sip-4.12.3-python-3.2.patch
@@ -1,44 +1,90 @@
+http://www.riverbankcomputing.co.uk/hg/sip/rev/3d0336c32dfa
+http://www.riverbankcomputing.co.uk/hg/sip/rev/df42f6bf92c8
+
--- siplib/sip.h.in
+++ siplib/sip.h.in
-@@ -1553,9 +1553,15 @@
+@@ -1553,9 +1553,13 @@
#define sipIsExactWrappedType(wt) (sipTypeAsPyTypeObject((wt)->type) == (PyTypeObject *)(wt))
+-#define sipConvertFromSliceObject(o,len,start,stop,step,slen) \
+#if PY_VERSION_HEX >= 0x03020000
-+#define sipConvertFromSliceObject(o,len,start,stop,step,slen) \
-+ PySlice_GetIndicesEx((o), (len), (start), (stop), \
-+ (step), (slen))
++#define sipConvertFromSliceObject PySlice_GetIndicesEx
+#else
- #define sipConvertFromSliceObject(o,len,start,stop,step,slen) \
++#define sipConvertFromSliceObject(o, len, start, stop, step, slen) \
PySlice_GetIndicesEx((PySliceObject *)(o), (len), (start), (stop), \
(step), (slen))
+#endif
/*
---- siplib/voidptr.c
-+++ siplib/voidptr.c
-@@ -429,7 +429,11 @@
+--- siplib/siplib.c.in
++++ siplib/siplib.c.in
+@@ -9216,9 +9216,9 @@
+ const sipClassTypeDef *ctd;
+
+ if ((ptr = getPtrTypeDef(self, &ctd)) == NULL)
+- return -1;
++ return;
+
+- return ctd->ctd_releasebuffer((PyObject *)self, ptr, buf);
++ ctd->ctd_releasebuffer((PyObject *)self, ptr, buf);
+ }
+ #endif
+
+@@ -10686,7 +10686,11 @@
+ if ((wc = sip_api_malloc(ulen * sizeof (wchar_t))) == NULL)
+ return -1;
+
++#if PY_VERSION_HEX >= 0x03020000
++ ulen = PyUnicode_AsWideChar(obj, wc, ulen);
++#else
+ ulen = PyUnicode_AsWideChar((PyUnicodeObject *)obj, wc, ulen);
++#endif
+
+ if (ulen < 0)
{
- Py_ssize_t start, stop, step, slicelength;
+@@ -10737,7 +10741,11 @@
+ if (PyUnicode_GET_SIZE(obj) != 1)
+ return -1;
+
++#if PY_VERSION_HEX >= 0x03020000
++ if (PyUnicode_AsWideChar(obj, ap, 1) != 1)
++#else
+ if (PyUnicode_AsWideChar((PyUnicodeObject *)obj, ap, 1) != 1)
++#endif
+ return -1;
+
+ return 0;
+@@ -10793,7 +10801,11 @@
+ if ((wc = sip_api_malloc((ulen + 1) * sizeof (wchar_t))) == NULL)
+ return -1;
+#if PY_VERSION_HEX >= 0x03020000
-+ if (PySlice_GetIndicesEx(key, v->size, &start, &stop, &step, &slicelength) < 0)
++ ulen = PyUnicode_AsWideChar(obj, wc, ulen);
+#else
- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &slicelength) < 0)
+ ulen = PyUnicode_AsWideChar((PyUnicodeObject *)obj, wc, ulen);
+#endif
+
+ if (ulen < 0)
+ {
+--- siplib/voidptr.c
++++ siplib/voidptr.c
+@@ -429,7 +429,7 @@
+ {
+ Py_ssize_t start, stop, step, slicelength;
+
+- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &slicelength) < 0)
++ if (sipConvertFromSliceObject(key, v->size, &start, &stop, &step, &slicelength) < 0)
return NULL;
if (step != 1)
-@@ -486,7 +490,11 @@
+@@ -486,7 +486,7 @@
{
Py_ssize_t stop, step;
-+#if PY_VERSION_HEX >= 0x03020000
-+ if (PySlice_GetIndicesEx(key, v->size, &start, &stop, &step, &size) < 0)
-+#else
- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &size) < 0)
-+#endif
+- if (PySlice_GetIndicesEx((PySliceObject *)key, v->size, &start, &stop, &step, &size) < 0)
++ if (sipConvertFromSliceObject(key, v->size, &start, &stop, &step, &size) < 0)
return -1;
if (step != 1)
diff --git a/dev-python/sip/sip-4.12.3-r1.ebuild b/dev-python/sip/sip-4.12.3-r2.ebuild
index 101aab2bf54c..319b3d89a4a9 100644
--- a/dev-python/sip/sip-4.12.3-r1.ebuild
+++ b/dev-python/sip/sip-4.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.3-r1.ebuild,v 1.1 2011/06/24 20:39:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.12.3-r2.ebuild,v 1.1 2011/06/25 09:12:46 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="*"