summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-09-25 08:04:14 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-09-25 08:04:14 +0000
commite6fb7085a39fcea6545ba4a947119359d7d3fe02 (patch)
tree38da52b9bff983e244a1c267f9fcdf441dbce5a3 /dev-python/requests
parentVersion bump. (diff)
downloadgentoo-2-e6fb7085a39fcea6545ba4a947119359d7d3fe02.tar.gz
gentoo-2-e6fb7085a39fcea6545ba4a947119359d7d3fe02.tar.bz2
gentoo-2-e6fb7085a39fcea6545ba4a947119359d7d3fe02.zip
Remove old versions.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-0.14.2.ebuild56
-rw-r--r--dev-python/requests/requests-1.0.4.ebuild45
-rw-r--r--dev-python/requests/requests-1.1.0.ebuild45
-rw-r--r--dev-python/requests/requests-1.2.0.ebuild45
-rw-r--r--dev-python/requests/requests-1.2.1.ebuild46
-rw-r--r--dev-python/requests/requests-1.2.2.ebuild46
7 files changed, 6 insertions, 284 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index d19ab75d127b..ed7957e619b0 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.43 2013/09/05 18:46:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.44 2013/09/25 08:04:14 djc Exp $
+
+ 25 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> -requests-0.14.2.ebuild,
+ -requests-1.0.4.ebuild, -requests-1.1.0.ebuild, -requests-1.2.0.ebuild,
+ -requests-1.2.1.ebuild, -requests-1.2.2.ebuild:
+ Remove old versions.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> requests-1.0.4.ebuild,
requests-1.1.0.ebuild, requests-1.2.0.ebuild, requests-1.2.1.ebuild,
diff --git a/dev-python/requests/requests-0.14.2.ebuild b/dev-python/requests/requests-0.14.2.ebuild
deleted file mode 100644
index 689289ef5ac5..000000000000
--- a/dev-python/requests/requests-0.14.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-0.14.2.ebuild,v 1.1 2012/10/30 09:37:14 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils eutils
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RDEPEND="app-misc/ca-certificates
- dev-python/chardet
- dev-python/oauthlib
- dev-python/urllib3"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES=1
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-src_prepare() {
- # use system libs for chardet, oauthlib, and urllib3
- rm -r requests/packages || die
- epatch "${FILESDIR}"/${PN}-0.14.1-system-libs.patch
-
- # use system ca-certificates
- rm requests/cacert.pem || die
- epatch "${FILESDIR}"/${PN}-0.14.1-system-cacerts.patch
-
- # Different packages are installed depending on the python version.
- # Need to remove stale egg-info data and build in separate directories.
- rm -r requests.egg-info || die
-
- distutils_src_prepare
-}
-
-src_test() {
- echoit() { echo "$@"; "$@"; }
- testing() {
- echoit nosetests --verbosity=1 tests/*.py
- }
- python_execute_function testing
-}
diff --git a/dev-python/requests/requests-1.0.4.ebuild b/dev-python/requests/requests-1.0.4.ebuild
deleted file mode 100644
index ea09af7448f3..000000000000
--- a/dev-python/requests/requests-1.0.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.0.4.ebuild,v 1.3 2013/09/05 18:46:21 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]
- dev-python/urllib3"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-system-libs.patch )
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- # use system libs for charade and urllib3
- rm -r requests/packages || die
-
- # use system ca-certificates
- rm requests/cacert.pem || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die
-}
diff --git a/dev-python/requests/requests-1.1.0.ebuild b/dev-python/requests/requests-1.1.0.ebuild
deleted file mode 100644
index bef687cab9f4..000000000000
--- a/dev-python/requests/requests-1.1.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.1.0.ebuild,v 1.5 2013/09/05 18:46:21 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${P}-system-cacerts.patch
- "${FILESDIR}"/${P}-system-libs.patch
- )
-
- # use system charade
- rm -r requests/packages/charade || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests/requests-1.2.0.ebuild b/dev-python/requests/requests-1.2.0.ebuild
deleted file mode 100644
index 74da12a45145..000000000000
--- a/dev-python/requests/requests-1.2.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.2.0.ebuild,v 1.4 2013/09/05 18:46:21 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${P}-system-cacerts.patch
- "${FILESDIR}"/${P}-system-libs.patch
- )
-
- # use system charade
- rm -r requests/packages/charade || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests/requests-1.2.1.ebuild b/dev-python/requests/requests-1.2.1.ebuild
deleted file mode 100644
index a1884392a1bc..000000000000
--- a/dev-python/requests/requests-1.2.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.2.1.ebuild,v 1.2 2013/09/05 18:46:21 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-1.2.0-system-cacerts.patch
- "${FILESDIR}"/${PN}-1.2.0-system-libs.patch
- "${FILESDIR}"/${P}-urllib3-py3.patch
- )
-
- # use system charade
- rm -r requests/packages/charade || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests/requests-1.2.2.ebuild b/dev-python/requests/requests-1.2.2.ebuild
deleted file mode 100644
index adc4ba85851d..000000000000
--- a/dev-python/requests/requests-1.2.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-1.2.2.ebuild,v 1.2 2013/09/05 18:46:21 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-# bundles dev-python/urllib3 snapshot
-RDEPEND="app-misc/ca-certificates
- dev-python/charade[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-DOCS=( README.rst HISTORY.rst )
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-1.2.0-system-cacerts.patch
- "${FILESDIR}"/${PN}-1.2.0-system-libs.patch
- "${FILESDIR}"/${PN}-1.2.1-urllib3-py3.patch
- )
-
- # use system charade
- rm -r requests/packages/charade || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}